HDOJ 题目1829A Bug's Life(分组并查集)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8829    Accepted Submission(s): 2846


Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source
 
典型的分组并查集,思路1是用两个并查集看两组是否有冲突
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int pre[100010];
int n,m;
int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	return r;
}
void fun(int a,int b)
{
	int fx,fy;
	fx=find(a);
	fy=find(b);
	if(fx!=fy)
	{
		pre[fx]=fy;
	}
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		//int n,m;
		int w=1,i;
		scanf("%d%d",&n,&m);
		for(i=0;i<=n*2;i++)
		{
			pre[i]=i;
		}
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			fun(a,b+n);
			fun(b,a+n);
			if(find(a)==find(a+n)||find(b)==find(b+n))
			{
				w=0;				
			}
		}
		printf("Scenario #%d:\n",++c);
		if(w)
			printf("No suspicious bugs found!\n");
		else
			printf("Suspicious bugs found!\n");
		//if(t)
			printf("\n");//每个后边都要有个空格
	}
}

方法二 开一个并查集,但是要加个偏移向量数组,来记录每个节点距离根节点的距离
ac代码
#include<stdio.h>
#include<string.h>
int pre[100010],d[100010];
int find(int x)
{
	if(x==pre[x])
		return x;
	else
	{
		int px=pre[x];
		pre[x]=find(pre[x]);
		d[x]=(d[px]+d[x])%2;//注意对二取余
		return pre[x];
	}
}
int fun(int x,int y)
{
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		d[fx]=(d[y]-d[x]+1)%2;//保证x到顶点距离比y大一
	}
	find(x);//更新x那支上的所有点的到顶点距离值
}
int main()
{
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,w=1,i;
		scanf("%d%d",&n,&m);
		for(i=0;i<=n;i++)
		{
			pre[i]=i;
			d[i]=0;
		}
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			if(w)
				fun(a,b);
			if(d[a]==d[b])
				w=0;
		}
		printf("Scenario #%d:\n",++c);
		if(w)
			printf("No suspicious bugs found!\n");
		else
			printf("Suspicious bugs found!\n");
		printf("\n");
	}	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值