Hduuoj1034【水题】

/*Candy Sharing Game
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3782    Accepted Submission(s): 2359


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of 
candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right
. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all 
students have the same number of pieces of candy. 
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for 
each student from the amount of candy each child starts with.

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) 
candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number 
is on a line by itself.

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input
6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0
 

Sample Output
15 14
17 22
4 8

Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

Source
Greater New York 2003 

Recommend
We have carefully selected several similar problems for you:  1035 1037 1038 1036 1062 
*/
#include<stdio.h>
#include<stdlib.h>
#include<malloc.h>
int main()
{
	int i, j, k, n;
	while(scanf("%d", &n) != EOF && n)
	{
		int * a = (int *)malloc(n * sizeof(int));
		int * b = (int *)malloc(n * sizeof(int));
		for(i = 0; i < n; ++i)
		scanf("%d", &a[i]);
		int cnt = 0;
		while(1)
		{
			for(i = 1; i < n; ++i)
			if(a[i] != a[0])
			break;
			if(i == n)
			break;
			for(i = 0; i < n; ++i)
			{
				a[i]>>=1;
				b[i] = a[i];
			}
			for(i = 0; i < n; ++i)
			{
				if(i == 0)
				a[i] += b[n-1];
				else
				a[i] += b[i-1];
				if(a[i] & 1)
				a[i]++;
			}
			cnt++;
		}
		printf("%d %d\n", cnt, a[0]); 
		free(a);
		free(b);
	} 
	return 0;
} 

题意:老师在中间,学生围着老师成一个圈,刚开始每个学生手里都有偶数颗糖,老师每吹一次口哨,每一个学生都要将手里的一半糖给右手边的同学,当这一轮结束后若有的学生手里的糖的个数是奇数你,那么老师会给这个学生补上一课糖,求经过多少轮后每个学生手里的糖个数一样,并且输出糖的个数。

思路:开2个数组,a数组模拟现有的糖,b数组代表过程中每个学生的手里的一半糖然后每个学生按照过程累加就是了。每过一轮进行一次判断,直至相同。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值