Hduojo1059【01背包】

/*Dividing
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21856    Accepted Submission(s): 6168


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.

 

Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 

Sample Output
Collection #1:
Can't be divided.

Collection #2:
Can be divided.
 

Source
Mid-Central European Regional Contest 1999 
*/
#include<stdio.h>
#include<string.h>
int cas = 1,  w[110], dp[420000];
int main()
{
	int i, j, k, num[7], sum;
	while(scanf("%d%d%d%d%d%d", &num[1], &num[2], &num[3], &num[4], &num[5], &num[6]) != EOF)
	{
		if(!num[1] &&!num[2] &&!num[3] &&!num[4] &&!num[5] &&!num[6] )
		break;
		printf("Collection #%d:\n", cas++);
		sum = num[1]+2*num[2]+3*num[3]+4*num[4]+5*num[5]+6*num[6];
		if(sum & 1)
		{
			printf("Can't be divided.\n\n");
			continue;
		}
		k = 0;
		for(i = 1; i <= 6; ++i)
		{
			for(j = 1; j <= num[i]; j <<= 1)//件数拆分 
			{
				w[k++] = j*i;
				num[i] -= j;
			}
			if(num[i] > 0)
			w[k++] = num[i] * i;
		}
		sum /= 2; 
		memset(dp, 0, sizeof(dp));
		for(i = 0; i < k; ++i)
		for(j = sum; j >= w[i]; --j)
		if(dp[j] < dp[j - w[i]] + w[i])
		dp[j] = dp[j - w[i]] + w[i];
		if(dp[sum] == sum)
		printf("Can be divided.\n\n");
		else
		printf("Can't be divided.\n\n");
	}
	return 0;
} 


题意:有n个价值为1-6的弹球,求是否能将弹球平分成价值一样的2堆。

思路:对于输入数据价值只有6种,然而每一种价值的个数却高达20000,如果用母函数的话肯定是超时的。我们将弹球看作是价值和容量一样的物品,并且用num数组保存每种弹球的个数,我们将num[i]进行二进制拆分,将第i种弹球拆分成n件不同的物品(价值和容量还是一样的物品),但是这n件物品仍然可以组合成1-num[i]件第i种弹球。全部拆分完毕后即可进行01背包.最后判断dp[总和的一半]的数值是否和总和的一半相等。

PS:当总和为奇数时,直接输出Can‘t

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值