1006. Sign In and Sign Out (25)

1006. Sign In and Sign Out (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月17日 20:16答案正确251006C++ (g++ 4.7.2)1364datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确12442/2
1答案正确13644/4
2答案正确12564/4
3答案正确13644/4
4答案正确13645/5
5答案正确12566/6
#include<iostream>
#include<string>
using namespace std;
bool CompareTime(string tmax,string tmin)
{ 
   if(tmax[0]>tmin[0])
     return true;
   else if(tmax[0]==tmin[0])
   {
     if(tmax[1]>tmin[1]) return true;
     else if(tmax[1]==tmin[1])
     {
            if(tmax[3]>tmin[3]) return true;
      else if(tmax[3]==tmin[3])
      {
        if(tmax[4]>tmin[4]) return true; 
          else if(tmax[4]==tmin[4])
        {
          if(tmax[6]>tmin[6]) return true;
          else if(tmax[6]==tmin[6]&&tmax[7]>tmin[7])
                return true;  
        }
      }
     }
   }
   return false;
}
int main()
{
  int M;
  string ID_number1,Sign_in_time,Sign_out_time,n1,t1,t2,ID_number12;
    cin>>M; 
  cin>>ID_number1>>Sign_in_time>>Sign_out_time;
  ID_number12=ID_number1;
  M--;
  while(M--)
  {
    cin>>n1>>t1>>t2;
        if(CompareTime(Sign_in_time,t1))
    {
           Sign_in_time=t1;
       ID_number1=n1;
    }
    if(CompareTime(t2,Sign_out_time))
    {
      Sign_out_time=t2;
      ID_number12=n1;
    }
  }
  cout<<ID_number1<<" "<<ID_number12<<endl;
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值