【PAT】A1099. Build A Binary Search Tree (30)

Author: CHEN, Yue

Organization: 浙江大学

Time Limit: 200 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

A1099. Build A Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Snip20160811_82



Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format “left_index right_index”, provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

 

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

 

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42


Sample Output:

58 25 82 11 38 67 45 73 42

Code

#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int n, data[maxn], left, right, index = 0;
vector<int> vnode[maxn], result;
typedef struct node{
	int data, right, left;
}node;
node nodes[maxn];
void inorder(int root){
	if (nodes[root].left != -1)
		inorder(nodes[root].left);
	nodes[root].data = data[index++];
	if (nodes[root].right != -1)
		inorder(nodes[root].right);
}
void levelorder(int root){
	queue<int> qi;
	qi.push(root);
	while (!qi.empty()){
		int now = qi.front();
		qi.pop();
		result.push_back(nodes[now].data);
		if (nodes[now].left != -1)	qi.push(nodes[now].left);
		if (nodes[now].right != -1)	qi.push(nodes[now].right);
	}
}
int main(){
	scanf("%d", &n);
	for (int i = 0; i < n; i++){
		scanf("%d %d", &left, &right);
		nodes[i].left = left;
		nodes[i].right = right;
	}
	for (int i = 0; i < n; i++)
		scanf("%d", &data[i]);
	sort(data, data + n);
	inorder(0);
	levelorder(0);
	for (int i = 0; i < n; i++){
		if (i)	printf(" ");
		printf("%d", result[i]);
	}
	printf("\n");
	return 0;
}

Analysis

-已知一颗二叉排序树的树型,并且给出n个key值。要求将这n个key值放入给出的树型中,且满足二叉排序树的要求。最后输出其层序遍历。

-使用中序遍历的思想,按照中序遍历的顺序向对应位置,按按序添入key值(先将key值按升序排列)。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值