【PAT】Boys vs Girls (25)

题目描述

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

翻译:这次你需要说出女生最高分和男生最低分之间的区别。

INPUT FORMAT

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

翻译:每个输入文件包含一组测试数据。对于每组输入数据,包括一个正整数N,接着是N行学生信息。每行包括一个学生的姓名,性别,ID和成绩,用空格隔开。姓名和ID是不超过10个字符的不包括空格的字符串,性别不是F(女)就是M(男),成绩是一个0-100之间的整数。数据保证每个成绩都是唯一的。

OUTPUT FORMAT

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

翻译:对于每组输入数据,输出3行。第一行为得分最高的女生的姓名和ID,第二行是得分最低的男生的姓名和ID。第三行为女生最高分数和男生最低分数之差。如果没有这种学生(没有男生或女生),则在对应位置输出“Absent”,并在第三行输出“NA”。


Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6


Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA


解题思路

定义一个结构体保存学生数据,用boy和girl分别代表男生中分最低的和女生中分最高的,根据题目描述模拟即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
struct Stu{
    string Name;
    string ID;
    int grade;
    Stu(string n,string id,int g):Name(n),ID(id),grade(g){}
    bool operator<(const Stu &a)const{
        return grade<a.grade;
    }
}; 
int N;
Stu boy("","",101),girl("","",-1);
int main(){
    scanf("%d",&N);
    string n,id;
    char sex;
    int g;
    for(int i=0;i<N;i++){
        cin>>n>>sex>>id>>g;
        Stu temp(n,id,g);
        if(sex=='M'&&temp<boy)boy=temp;
        if(sex=='F'&&girl<temp)girl=temp;
    }
    if(girl.grade>=0)cout<<girl.Name<<" "<<girl.ID<<endl;
    else cout<<"Absent"<<endl;
    if(boy.grade<=100)cout<<boy.Name<<" "<<boy.ID<<endl;
    else cout<<"Absent"<<endl;
    if(boy.grade<=100&&girl.grade>=0)cout<<abs(girl.grade-boy.grade)<<endl;
    else cout<<"NA"<<endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值