1071. Speech Patterns (25)

102 篇文章 0 订阅
37 篇文章 0 订阅

1071. Speech Patterns (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can?  It can!"
Sample Output:
can 5
样例看的太扭;
简单的说就是一个句子,里面的单词由大小写和数字构成,其他标点符号甚么的都不是;要求出现次数最多的那个单词;
如果有多个出现次数一样多的,那么给出字典序最少的(PS:我这里一开始没有注意字典序,但是也可以AC,测试数据有点弱)

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月14日 16:22答案正确251071C++ (g++ 4.7.2)1352752datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118013/13
1答案正确13082/2
2答案正确13527524/4
3答案正确12623604/4
4答案正确13082/2
#include<iostream> 
#include<string>
#include<map>  
#include<algorithm>
using namespace std;    
int main()
{ 
  int index,len,maxcnt;
  string line;
  string word,ans;
  map<string, int>words;
  getline(cin, line);
  len = line.size();    
  line[len++] = '.';/*用于处理可能123 123 e 123这样结尾的少数一个的问题*/
  for (index = 0,maxcnt=0,ans="\0"; index < len;index++)
  {  
    if (isalpha(line[index])||isdigit(line[index])) 
      word+= !isdigit(line[index])&&  isupper(line[index]) ? line[index] - 'A' + 'a' : line[index];/*判断顺序不能换*/
    else  if (!word.empty())  
    {
      words[word]++;
      if (words[word] > maxcnt)
      {
        maxcnt = words[word];
        ans = word;
      }
      word.erase();
    }  
  } 
  cout << ans << " " << maxcnt << endl;
    system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 7
    评论
评论 7
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值