1093. Count PAT's (25)

102 篇文章 0 订阅
26 篇文章 0 订阅

1093. Count PAT's (25)

时间限制
120 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 105characters containing only P, A, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:
APPAPT
Sample Output:
2
看看一串按着原来的顺序的不一定要相连的能有几个PAT;
输出几个;如果这个答案很大的话这里是大于或等于1000000007,就要对1000000007取模%mod;
我下面的代码str[2]代表当前index至后面包括index有多少个T;
          str[1]代表当前index至后面包括index有多少个AT;
          str[0]代表当前index至后面包括index有多少个PAT;
误认为溢出才输出1000000007,并且最开始+str[1]*s[0];这个思想是错误的。比如PATPAT这里只有4个如果用乘的化就会变成5个。

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月19日 09:36答案正确251093C++ (g++ 4.7.2)5516datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118014/14
1答案正确14361/1
2答案正确55002/2
3答案正确55164/4
4答案正确54364/4
#include<iostream> 
#include<string>  
using namespace std;  
int main()
{
  string  patstr; 
  bool Flag = true;
  int str[3] = { 0 };
  int index;
  getline(cin, patstr); 
  for (index = patstr.size() - 1; index >= 0 && Flag; index--)
  {
    if (patstr[index] == 'T')
      str[2]++;
    else if (patstr[index] == 'A')
      str[1] += str[2];
    else
    { 
      str[0] += str[1]%1000000007;
      str[0]%= 1000000007;
    }
  } cout << str[0] << endl;
  system("pause");
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值