Counting Triangles - HUD 1396 递推

73 篇文章 0 订阅

Counting Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2051    Accepted Submission(s): 980


Problem Description
Given an equilateral triangle with n the length of its side, program to count how many triangles in it.



 

Input
The length n (n <= 500) of the equilateral triangle's side, one per line.

process to the end of the file
 

Output
The number of triangles in the equilateral triangle, one per line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 5 13

题意:中文不用翻译。

思路:定三个数组,a[]代表第几行的正三角形个数,b[]代表第几行的反三角形个数。sum[]代表总和。

           可以找下规律:     a[1]=1                                  b[1]=0

                                         a[2]=2+1                              b[2]=1

                                         a[3]=3+2+1                          b[3]=2

                                         a[4]=4+3+2+1                      b[4]=3+1

                                         a[5]=5+4+3+2+1                  b[5]=4+2

                                         a[6]=6+5+4+3+2+1              b[6]=5+3+1

                                         a[7]=7+6+5+4+3+2+1          b[7]=6+4+2

                                         a[n]=n+a[n-1]                        b[n]=n-1+b[n-2]

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
long long a[510],b[510],sum[510];
int main()
{ int i,j,k;
  for(i=1;i<=500;i++)
   a[i]=i+a[i-1];
  for(i=2;i<=500;i++)
   b[i]=i-1+b[i-2];
  for(i=1;i<=500;i++)
   sum[i]=sum[i-1]+a[i]+b[i];
  while(~scanf("%d",&k))
   printf("%lld\n",sum[k]);
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值