Dance Dance Revolution - UVa 1291 dp

Mr. White, a fat man, now is crazy about a game named ``Dance, Dance, Revolution". But his dance skill is so poor that he could not dance a dance, even if he dances arduously every time. Does ``DDR" just mean him a perfect method to squander his pounds? No way. He still expects that he will be regarded as ``Terpsichorean White" one day. So he is considering writing a program to plan the movement sequence of his feet, so that he may save his strength on dancing. Now he looks forward to dancing easily instead of sweatily.

``DDR" is a dancing game that requires the dancer to use his feet to tread on the points according to the direction sequence in the game. There are one central point and four side points in the game. Those side points are classified as top, left, bottom and right. For the sake of explanation, we mark them integers. That is, the central point is 0, the top is 1, the left is 2, the bottom is 3, and the right is 4, as the figure below shows:


At the beginning the dancer's two feet stay on the central point. According to the direction sequence, the dancer has to move one of his feet to the special points. For example, if the sequence requires him to move to the top point at first, he may move either of his feet from point 0 to point 1 (Note: Not both of his feet). Also, if the sequence then requires him to move to the bottom point, he may move either of his feet to point 3, regardless whether to use the foot that stays on point 0 or the one that stays on point 1.

There is a strange rule in the game: moving both of his feet to the same point is not allowed. For instance, if the sequence requires the dancer to the bottom point and one of his feet already sta ys on point 3, he should stay the very foot on the same point and tread again, instead of moving the other one to point 3.

After dancing for a long time, Mr. White can calculate how much strength will be consumed when he moves from one point to another. Moving one of his feet from the central point to any side points will consume 2 units of his strength. Moving from one side point to another adjacent side point will consume 3 units, such as from the top point to the left point. Moving from one side point to the opposite side point will consume 4 units, such as from the top point to the bottom point. Yet, if he stays on the same point and tread again, he will use 1 unit.

Assume that the sequence requires Mr. White to move to point $ \rightarrow$ 2 $ \rightarrow$ 2 $ \rightarrow$ 4. His feet may stays on (point 0, point 0) $ \rightarrow$ (0, 1) $ \rightarrow$ (2, 1) $ \rightarrow$ (2, 1) $ \rightarrow$ (2, 4). In this couple of integers, the former number represents the point of his left foot, and the latter represents the point of his right foot. In this way, he has to consume 8 units of his strength. If he tries another pas, he will have to consume much more strength. The 8 units of strength is the least cost.

Input 

The input file will consist of a series of direction sequences. Each direction sequence contains a sequence of numbers. Ea ch number should either be 1, 2, 3, or 4, and each represents one of the four directions. A value of 0 in the direction sequence indicates the end of direction sequence. And this value should be excluded from the direction sequence. The input file ends if the sequence contains a single 0.

Output 

For each direction sequence, print the least units of strength will be consumed. The result should be a single integer on a line by itself. Any more white spaces or blank lines are not allowable.

Sample Input 

1 2 2 4 0 
1 2 3 4 1 2 3 3 4 2 0 
0

Sample Output 

8 
22

题意:在跳舞机上,最开始两只脚在0,0处,且之后不允许两只脚在一起。从0到其他点需要两点体力,到相邻的点需要3点体力,到对立的点需要4点体力,问最后体力的最小消耗值。

思路:滚动数组进行递推,没什么好说的。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
using namespace std;
int dp[2][5][5],INF=1e9,a,b,cost[5][5];
void init(int b)
{
    int i,j,k;
    for(i=0;i<=4;i++)
       for(j=0;j<=4;j++)
          dp[b][i][j]=INF;
}
void solve(int x,int y,int pos)
{
    int i,j,k;
    if(x==pos || y==pos)
      dp[b][x][y]=min(dp[b][x][y],dp[a][x][y]+1);
    else
    {
        dp[b][pos][y]=min(dp[b][pos][y],dp[a][x][y]+cost[x][pos]);
        dp[b][x][pos]=min(dp[b][x][pos],dp[a][x][y]+cost[y][pos]);
    }
}
int main()
{
    int i,j,k,temp,ans;
    for(i=1;i<=4;i++)
       cost[0][i]=2;
    for(i=1;i<=4;i++)
       for(j=1;j<=4;j++)
          if(i!=j)
          {
              if(abs(i-j)==2)
                cost[i][j]=4;
              else
                cost[i][j]=3;
          }
    while(~scanf("%d",&k) && k>0)
    {
        init(0);init(1);
        dp[0][0][0]=0;
        temp=1;a=0;b=1;
        solve(0,0,k);
        while(~scanf("%d",&k) && k>0)
        {
            temp++;
            if(temp&1)
              a=0,b=1;
            else
              a=1,b=0;
            init(b);
            for(i=0;i<=4;i++)
               for(j=0;j<=4;j++)
                  if(i!=j && dp[a][i][j]!=INF)
                    solve(i,j,k);
        }
        ans=INF;
        for(i=0;i<=4;i++)
           for(j=0;j<=4;j++)
              ans=min(ans,dp[b][i][j]);
        printf("%d\n",ans);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值