迷宫城堡
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 8401 Accepted Submission(s): 3760
Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
Sample Input
3 3 1 2 2 3 3 1 3 3 1 2 2 3 3 2 0 0
Sample Output
Yes No
题意:求是否所有房间之间都存在路径。
思路:Tarjan求强连通分量,如果强连通分量只有一个,就说明全部连通。
AC代码如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int v,next;
}edge[100010];
int Head[10010],stack[10010],DFN[10010],Low[10010],Belong[10010];
bool instack[10010];
int n,m,tot,top,cnt,scnt;
void init()
{
cnt=scnt=top=tot=0;
memset(Head,-1,sizeof(Head));
memset(DFN,0,sizeof(DFN));
}
void add(int u,int v)
{
edge[tot].v=v;
edge[tot].next=Head[u];
Head[u]=tot++;
}
void Tarjan(int u)
{
int i,j,k,v;
DFN[u]=Low[u]=++tot;
instack[u]=1;
stack[top++]=u;
for(i=Head[u];i!=-1;i=edge[i].next)
{
v=edge[i].v;
if(!DFN[v])
{
Tarjan(v);
Low[u]=min(Low[u],Low[v]);
}
else if(instack[v])
Low[u]=min(Low[u],DFN[v]);
}
if(DFN[u]==Low[u])
{
scnt++;
do
{
v=stack[--top];
instack[v]=0;
Belong[v]=scnt;
}while(u!=v);
}
}
int main()
{
int i,j,k,u,v;
while(~scanf("%d%d",&n,&m) && n+m>0)
{
init();
for(i=1;i<=m;i++)
{
scanf("%d%d",&u,&v);
add(u,v);
}
tot=0;
for(i=1;i<=n;i++)
if(!DFN[i])
Tarjan(i);
if(scnt==1)
printf("Yes\n");
else
printf("No\n");
}
}