HDU 1789 贪心

题目链接    :http://acm.hdu.edu.cn/showproblem.php?pid=1789

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

就是m个课程,一行是课程结束时间,一行是课程的价值,求怎样没学课程价值最小

比赛时纠结好久误解,哎~还是太年轻了啊,感觉要多做些贪心的题目了


详解在代码中


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 1005

struct stud{
int time,cost;
}f[N];

int vis[N];

int cmp(stud a,stud b)
{
    if(a.cost!=b.cost)  //先做最大消耗的
        return a.cost>b.cost;
    return a.time<b.time;  //消耗相同就做时间靠前的
}


int main()
{
    int n,i,t;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&f[i].time);

        for(i=0;i<n;i++)
            scanf("%d",&f[i].cost);

        sort(f,f+n,cmp);

        memset(vis,0,sizeof(vis));  

        int j,ans=0;

        for(i=0;i<n;i++)
        {
            j=f[i].time;

            while(j)    //这里是重点,找到当前消耗的时间期限的前一个空时间,干掉这件事
            {
                if(vis[j]==0)
                {
                    vis[j]=1;
                    break;
                }
                j--;
            }

            if(j==0)     //没有找到时间,这个任务无法完成
               ans+=f[i].cost;
        }

        printf("%d\n",ans);
    }
    return 0;

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值