hdu 1074 Doing Homework(状压DP)

115 篇文章 0 订阅
3 篇文章 0 订阅

Doing Homework

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output
2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word “English” appears earlier than the word “Math”, so we choose the first order. That is so-called alphabet order.

ps:状压DP,但是几乎没做过状压DP的题,所以就GG了。。
题目中的数据n<=15,那很可能就是一道暴力题了。但是搜索的话,n!的时间很明显不行,那么就有了状压DP,复杂度O(2^n)(好像在状压DP这类题中n的范围为<=16?)

状压DP怎样写这里就不说了,主要说一下第二个for循环为什么从n-1开始:
题目是按字典序输入数据的,而输出时又要求(如果两门课的先后顺序不影响结果的话)按字典序输出,基于这个原因
如果判断是dp[i].score>=dp[p].score+tmp的话,很明显要从0开始
如果判断是dp[i].score>dp[p].score+tmp的话,就要从n-1开始了

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int inf=0x3f3f3f3f;
const int maxn=(1<<15)+10;

struct node
{
    char s[110];
    int dead,cost;
} q[16];

struct Node
{
    int time,score,now,pre;
} dp[maxn];

void output(int x)//递归回溯输出
{
    if(dp[x].pre!=-1)
    {
        output(dp[x].pre);
        printf("%s\n",q[dp[x].now].s);
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
            scanf("%s %d%d",&q[i].s,&q[i].dead,&q[i].cost);
        int N=(1<<n)-1;
        dp[0].pre=-1;
        for(int i=1; i<=N; ++i)
        {
            dp[i].score=inf;
            for(int j=n-1; ~j; --j)
            {
                int tot=1<<j;
                if(i&tot)
                {
                    int p=i-tot;
                    int tmp=dp[p].time+q[j].cost-q[j].dead;
                    if(tmp<0)
                        tmp=0;
                    if(dp[i].score>dp[p].score+tmp)
                    {
                        dp[i].score=dp[p].score+tmp;
                        dp[i].now=j;
                        dp[i].pre=p;//记录上一个状态的位置
                        dp[i].time=dp[p].time+q[j].cost;
                    }
                }
            }
        }
        printf("%d\n",dp[N].score);
        output(N);
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值