HDU 1829 A Bug's Life (并査集)

Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
    
    
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
    
    
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!



题意,搞基的有没有,给出哪些虫子有关系,例如 a和b有关系(情侣关系),b和c有关系,a和c也有关系,那么就有搞基的

思路: 把虫子有关系的用并査集连在一起,男性为0,雌性为1,,具体在代码中


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N  2005

int father[N],num[N];
int n,m;

int cha(int x)
{
    if(x!=father[x])
    {
        int t=father[x];
        father[x]=cha(father[x]);
        num[x]=(num[x]+num[t])%2; //不懂看上篇hdu3038
    }
    return father[x];
}

int main()
{
    int i,ca=0,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);

        for(i=0;i<=n;i++)
        {
            father[i]=i;
            num[i]=0;  //不妨假设全部的为男性,当a和b有关系就假设b为女性
        }

        int a,b;
        int flag=0;

        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(flag) continue;
            int aa=cha(a);
            int bb=cha(b); 
            if(aa!=bb)
            {
                father[aa]=bb;
                num[aa]=(-num[a]+num[b]+1+2)%2;//同上注释出
            }
            else    //以前直接或间接有过相同伴侣
               {
                 if(num[aa]!=(-num[a]+num[b]+1+2)%2)
                 flag=1;
               }
        }


        printf("Scenario #%d:\n",++ca);

        if(flag)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");

       
            printf("\n");
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值