POJ 1679 The Unique MST

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source



题意:就是判断最小生成树是不是唯一的,换而言之就是最小生成树的一条边能不能被别的边代替


思路:先来一遍最小生成树,把加入最小生成树的边标记,然后一一去掉这条边,看看有没有边能代替这条边,也就是看最小生成树的值变不变


就说这么多了,应该清楚了吧,看代码吧



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 10005

struct stud{
int a,b,len;
}f[N];

int father[N],vis[N],n,m;
int sum;

int cmp(stud a,stud b)
{
    return a.len<b.len;
}

int cha(int x)
{
    if(x!=father[x])
        father[x]=cha(father[x]);
    return father[x];
}

int fdd(int x)
{
    int i;
    for(i=0;i<=n;i++)
        father[i]=i;

    int num=1,ans=0;
    for(i=0;i<m;i++)
    {
        if(i==x) continue;  //该标记的边不加入生成树

        int aa=cha(f[i].a);
        int bb=cha(f[i].b);
        if(aa!=bb)
        {
            father[aa]=bb;
            num++;

            ans+=f[i].len;

            if(num==n)
                break;
        }
    }

    if(num==n&&ans==sum) return 1; //记住必须是两个条件,缺一不可
    return 0;

}
int main()
{
    int t,i;
    scanf("%d",&t);

    while(t--)
    {
        scanf("%d%d",&n,&m);

        for(i=0;i<m;i++)
           scanf("%d%d%d",&f[i].a,&f[i].b,&f[i].len);

        for(i=0;i<=n;i++)
            father[i]=i;

        sort(f,f+m,cmp);  //按边排序

        int num=1;

        memset(vis,0,sizeof(vis));

        sum=0;
        for(i=0;i<m;i++)
        {
            int aa=cha(f[i].a);
            int bb=cha(f[i].b);
            if(aa!=bb)
            {
                father[aa]=bb;
                num++;
                vis[i]=1;   //标记加入生成树的边
                sum+=f[i].len;  //最小生成树的值为sum

                if(num==n)  break;  //n个点,需要n-1条边(num初始值为1)
            }
        }

        int flag=0;
        for(i=0;i<m;i++)
            if(vis[i])  //如果这条边加入到生成树,就看看有么有边能代替他
               if(fdd(i))  //如果能 break;
                  break;
                  
        if(i!=m)
            printf("Not Unique!\n");
        else
            printf("%d\n",sum);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值