POJ 1011 Sticks(经典dfs)

Language:
Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 120720 Accepted: 27951

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

Source



题意:给你紧跟棍子,问可能是哪几根相同的棍子截成的,求可能的棍子的最小值


很难的dfs,剪枝很重要,我也是看别人题解的⊙﹏⊙b汗,解释在代码中




#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;

#define N 105

int a[N],len,n;
int vis[N],sum;

int cmp(int a,int b)
{
    return a>b;
}

bool dfs(int pos,int temp,int cut)
{
    if(cut==sum/len)  //拼凑成功
        return true;

    int i;

    for(i=pos;i<n;i++)
    {
        if(vis[i]==0&&temp+a[i]==len)
        {
            vis[i]=1;
            if(dfs(0,0,cut+1)) //记住前面可能有没有用到的棍子,所以从0开始(下一个dfs会寻找没有用到的棍子)
                return true;

            vis[i]=0;//我不是很清楚这个地方为什么变回来⊙﹏⊙b汗,如果5是所需的,不用5用3+2会不一样????
                     //还有不变回来会错,求路过大神指点迷津
            return false;  //这是因为上面5是所需,取5没用(接下来拼凑不成),那么取2+3也没有,因为2+3比5灵活
        }
        else
            if(vis[i]==0&&temp+a[i]<len)
        {
            vis[i]=1;
            if(dfs(i+1,temp+a[i],cut))
                return true;

            vis[i]=0;
            if(temp==0)  return false;

            while(a[i]==a[i+1])//如果上一次取5没有,这次取5也拼不好
                i++;
        }
    }
    return false;
}

int main()
{
    int i;
    while(scanf("%d",&n),n)
    {
        sum=0;

        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }

        sort(a,a+n,cmp);  //降序

        for(len=a[0];len<=sum;len++)  //棍子不比比最长的段短  
        {
            if(sum%len)  continue;  //肯定是该长度的倍数

            memset(vis,0,sizeof(vis));

            if(dfs(0,0,0))
            {
                printf("%d\n",len); 
                break;
            }
        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值