HDU 2586 How far away ?(LCA)

How far away ?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14755    Accepted Submission(s): 5603


Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 

Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 

Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 

Sample Input
  
  
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 

Sample Output
  
  
10 25 100 100
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   3486  2874  2888  3234  3047 




#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
#include<stack>
#include<cmath>
#include<map>
#include<set>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
#define bug(x) cout << x << endl;
using namespace std;
#define eps 1e-8
#define N 40005

struct Data
{
    Data(int t, int d):to(t),dis(d){}
    int to;
    int dis;
};

int dp[N][32];
vector<Data>g[N];
int n,m;
int dep[N];
int Dis[N];

void init()
{
    for (int i = 0; i <= n; i++)
        g[i].clear();
    memset(dp, -1, sizeof(dp));
}


void dfs(int u, int pre)
{
    for (int i = 0; i < g[u].size(); i++)
    {
        int to = g[u][i].to;
        if (to == pre) continue;
        dep[to] = dep[u] + 1;
        dp[to][0] = u;
        Dis[to] = Dis[u] + g[u][i].dis;
        dfs(to, u);
    }
}

void preDeal()
{
    for(int j = 0; (1<<j)<=n; j++)
    {
        for(int i = 1; i<=n; i++)
        {
            if (dp[i][j-1]!= -1)
                dp[i][j] = dp[dp[i][j-1]][j-1];
        }
    }
}

inline int LCA(int a, int b)
{
    if (dep[a] < dep[b])
        swap(a, b);

    int nCent = 0;
    while((1<<nCent)<dep[a])
        nCent ++;

    for (int i = nCent; i>=0; i--)
        if(dp[a][i-1]!= -1 && dep[dp[a][i-1]] >= dep[b])
            a = dp[a][i-1];

    if (a == b)
        return a;
    for (int i = nCent; i>=0; i--)
    {
        if (dp[a][i]!=-1 && dp[b][i] != -1 && dp[a][i]!= dp[b][i])
        {
            a = dp[a][i];
            b = dp[b][i];
        }
    }
    return dp[a][0];
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d",&n, &m);
        init();
        int from, to, dis;
        for (int i = 1; i < n;i++)
        {
            scanf("%d%d%d", &from, &to, &dis);
            g[from].push_back(Data(to, dis));
            g[to].push_back(Data(from, dis));
        }
        Dis[1]=0;
        dep[1]= 0;
        dfs(1, -1);
        preDeal();
        while(m--)
        {
            scanf("%d%d",&from, &to);
            int commAncester = LCA(from, to);
            printf("%d\n", Dis[from] + Dis[to] - Dis[commAncester]* 2);
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值