hdu_2642 Stars 线段树+点修改

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 1196    Accepted Submission(s): 485


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 


 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 


 

Output
For each query,output the number of bright stars in one line.
 


 

Sample Input
  
  
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 


 

Sample Output
  
  
1 0

 

#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define FOR(a,b) for(int i =  a ; i < b ; i++)
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define FOPENIN(IN) freopen(IN, "r", stdin)
#define FOPENOUT(OUT) freopen(OUT, "w", stdout)
const int num = 1000+10;
int M;
int c[num][num],a[num][num];
int lowbit(int x){
    return x&(-x);
}
void add(int x,int y,int k){
    for(int i = x ; i > 0 ; i-=lowbit(i))
        for(int j = y ; j > 0 ; j-=lowbit(j))
           c[i][j]+=k;
}
int Getsum(int x,int y){
    int ans = 0 ;
    for(int i = x ; i < num ; i+= lowbit(i))
        for(int j = y ; j < num ; j+= lowbit(j)){
            ans += c[i][j];
    }

    return ans;
}
int main()
{
    while(scanf("%d",&M)!=EOF){
        mem0(a);mem0(c);
        while(M--){
            char cc;
            int x1,y1,x2,y2;
            cin>>cc;
            if(cc=='B'){
                scanf("%d%d",&x1,&y1);
                x1++;y1++;
                if(a[x1][y1])continue;
                a[x1][y1]=1;
                add(x1,y1,1);
//                printf("\n******\n");
            }
            else if(cc=='D'){
                scanf("%d%d",&x1,&y1);
                x1++;y1++;
                if(a[x1][y1]==0)continue;
                a[x1][y1]=0;
                add(x1,y1,-1);
            }
            else if(cc=='Q'){
                scanf("%d%d%d%d",&x1,&x2,&y1,&y2);
                x1++;y1++;x2++;y2++;
                if(x1>x2)swap(x1,x2);
                if(y1>y2)swap(y1,y2);
                int Sum=Getsum(x1,y1)-Getsum(x2+1,y1)-Getsum(x1,y2+1)+Getsum(x2+1,y2+1);
                printf("%d\n",Sum);
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值