PAT-A Count PAT‘s

5 篇文章 0 订阅

Problem:
The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10^5 characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

思路:
这道题假如使用暴力解法只能拿到15分,那么我们就想着怎么优化时间复杂度。我们可以降低到O(n),具体做法如下:
从0遍历到字符串的最后一个字符,若当前的字符s[i]为A时,sum要加上前面P出现次数乘后面T出现次数的结果,并在每一步中取余,最后输出即可。

这道需要注意的是,以下小细节没有处理好可能会导致超时或是答案错误:
1.没有使用char类型,而是用了string字符串
2.获取字符串长度时没有“一劳永逸”,而是在每次用到时都要重新调用函数计算长度
3.没有每一步都取模(这道题可能没影响,我猜的)

代码:

#include<bits/stdc++.h>
using namespace std;
char s[1000005];
int p[1000005], t;
int sum = 0;

int main()
{
    scanf("%s", s);
    int len = strlen(s);
    if(s[0] == 'P')
        p[0]++;
    for(int i = 1; i < len; i++)
    {
        p[i] = p[i-1];
        if(s[i] == 'P')
            p[i]++;
    }
    for(int i = len-1; i >= 0; i--)
    {
        if(s[i] == 'T')
            t++;
        else if(s[i] == 'A')
            sum += t * p[i];
        sum %= 1000000007;
    }
    printf("%d\n", sum);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值