2018_1_23_poj_2083

Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10047 Accepted: 4604

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.
A box fractal is defined as below :
  • A box fractal of degree 1 is simply
    X
  • A box fractal of degree 2 is
    X X
    X
    X X
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

Source

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
const int N=10000;
char map[N][N];

void print(int n,int x,int y){
	if(n==1){map[x][y]='X';return;}
	int m=1;
	for(int i=0;i<n-2;i++)
		m*=3;
	print(n-1,x,y);
	print(n-1,x,y+2*m);
	print(n-1,x+m,y+m);
	print(n-1,x+2*m,y);
	print(n-1,x+2*m,y+2*m);
}

void print2(int n,int m){
	for(int i=0;i<n;i++){
		for(int j=0;j<m;j++)
		putchar(map[i][j]);
		putchar('\n');
	}
}

int main(){
	int n; 
	while(scanf("%d",&n)!=EOF){
		int m=1;
		for(int i=0;i<n-1;i++)
		m*=3;
		for(int i=0;i<=m;i++)
		for(int j=0;j<=m;j++)
		map[i][j]=' ';
		if(n==-1)return 0;
		print(n,0,0);
		double t=3.0;
		
		print2(m,m);
		puts("-");
	
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值