Hi3535 移植valgrind

首先遗憾的是: Valgrind要求硬件为ARMv7 和 VFP, 而Hi353无VFP, 因此valgrind在Hi3535上是不可用的。

移植过程如下:

1. 下载valgrind最新版本,我使用的版本为valgrind-3.13.0.tar.bz2

http://valgrind.org/downloads/current.html

2. 将下载的valgrind包,放置合适文件夹,并压文件

tar -jxf valgrind-3.13.0.tar.bz2

3. 切换至解压后的目录

cd valgrind-3.13.0

4. 修改configure文件

  修改“armv7*”为“armv7* | arm*”

5. 生成Makefile

./configure --host=arm-hisiv100nptl-linux --prefix=/opt/valgrind CC=arm-hisiv100nptl-linux-gcc CPP=arm-hisiv100nptl-linux-cpp AR=arm-hisiv100nptl-linux-ar CPPFLAGS="-I/opt/hisi-linux-nptl/arm-hisiv100-linux/target/usr/include" LDFLAGS=="-L/opt/hisi-linux-nptl/arm-hisiv100-linux/target/usr/lib" --enable-only32bit

说明:

--prefix: 为安装文件夹

6. 编译

make

7. 安装

make install

注:安装文件夹为系统文件夹时,需切换到root用户进行

8. 复制安装文件夹下的bin和lib文件夹,到开发板上的对应位置,验证

./valgrind ls



9. 定位报错原因

查看硬件信息

cat /proc/cpuinfo


查看SDK中的readme_cn.txt



至此,确认Hi3535不支持VFP,无法使用valgrind.

阅读更多
个人分类: Hi3535
想对作者说点什么? 我来说一句

miniGUI 3.0.2 在Hi3535平台上的移植

2018年05月14日 288KB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭