POJ——3259 chong 虫洞

 

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 84469 Accepted: 31310

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back Tseconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

在探索他的许多农场时,农夫约翰发现了许多令人惊奇的虫洞。一个虫洞是非常奇怪的,因为它是一条单向的路径,在你进入虫洞之前的一段时间把你送到它的目的地!FJ的每个农场包括N个(1≤N≤500)方便编号为1.N,M(1≤M≤2 500)路径和W(1≤W≤2 0 0)虫洞的农田。由于FJ是一个狂热的时间旅行迷,他想做以下几件事:从某个领域开始,穿过一些路径和虫洞,然后在他最初离开之前回到起点。也许他能认识自己:)。为了帮助FJ找出这是否可能,他将向你提供他农场F(1≤F≤5)的完整地图。任何路径都不会超过10,000秒的行程,而且没有虫洞能使FJ及时返回超过10,000秒。

 

Bellman-Ford后, 利用负权边的判断来给出题目答案。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 5505
#define inf 0x3f3f3f
struct e {
	int u, v, k;
}edge[N];
int f, n, m, w;
int dis[N];
void bellman_ford() {
	bool flag;
	for (int i = 1; i <= n; i++) {
		dis[i] = inf;
	}
	dis[1] = 0;
	for (int i = 0; i < n - 1; i++) {
		flag = false;
		for (int j = 0; j < 2 * m + w; j++) {
			if (dis[edge[j].v] > dis[edge[j].u] + edge[j].k) {
				//cout << edge[j].u << " " << edge[j].v << " " << edge[j].k << endl;
				dis[edge[j].v] = dis[edge[j].u] + edge[j].k;
				flag = true;
			}
		}
		if (!flag)break;
	}
	for (int j = 0; j < 2 * m + w; j++) {
		if (dis[edge[j].v] > dis[edge[j].u] + edge[j].k) {
			cout << "YES" << endl;
			return;
		}
	}
	cout << "NO" << endl;
}
int main() {
	scanf("%d", &f);
	while (f--) {
		scanf("%d%d%d", &n, &m, &w);
		for (int i = 0; i < m; i++) {
			scanf("%d%d%d", &edge[2 * i].u, &edge[2 * i].v, &edge[2 * i].k);
			edge[2 * i + 1].u = edge[2 * i].v;
			edge[2 * i + 1].v = edge[2 * i].u;
			edge[2 * i + 1].k = edge[2 * i].k;
		}
		for (int i = 0; i < w; i++) {
			scanf("%d%d%d", &edge[i + 2 * m].u, &edge[i + 2 * m].v, &edge[i + 2 * m].k);
			edge[i + 2 * m].k = -edge[i + 2 * m].k;
		}
		bellman_ford();
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值