UVA - 524 Prime Ring Problem

Description

A ring is composed of n (even number) circles as shown in diagram. Put natural numbers  into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

 

 


Note: the number of first circle should always be 1.

 

Input 

n (0 < n <= 16)

 

Output 

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements.

 


You are to write a program that completes above process.

 

Sample Input 

6
8

 

Sample Output 

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 50;
int n,A[maxn] = {1},isp[maxn], vis[maxn];
void dfs(int cur)
{
    if(cur == n&& isp[A[0] + A[n - 1]]) {
        for(int i = 0; i < n; i++) {
            i ? printf(" %d", A[i]) : printf("%d", A[i]);
        }
        printf("\n");
    } else for(int i = 2; i <= n; i++) {
        if(!vis[i]&& isp[i + A[cur - 1]]) {
            A[cur] = i;
            vis[i] = 1;
            dfs(cur + 1);
            vis[i] = 0;
        }
    }
}
int main()
{
    for(int i =2;i<=50;i++)
    {
        isp[i] = 1;
    }
    for(int i = 2;i<=50;i++)
    {
        for(int j = i + i; j + i <= 50; j +=i)
        {
            isp[j] = 0;
        }
    }
    int kase = 0;
    while(cin>>n)
    {
        if(kase++)
        {
            cout<<"\n";
        }
        cout<<"Case "<<kase<<":\n";
        dfs(1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值