(PAT 1155) Heap Paths (堆+完全二叉树遍历)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

解题思路:

利用一个vector保留遍历时的路径(深度优先),每到达一个叶子节点就输出当前vector中的所有元素

至于大顶堆小顶堆,每遍历到一个结点就将这个结点和它的左右子结点比较,创建两个bool变量记录

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
const int MAXN = 1010;
int BinayTree[MAXN];
int N;
//root从0开始
bool MAXHEAP, MINHEAP;
vector<int> preorderTemp;
void preOrderTRA(int root) {
	preorderTemp.push_back(BinayTree[root]);  
	if (root * 2 + 1 >= N && root * 2 + 2 >= N) {
		for (auto itr = preorderTemp.begin(); itr != preorderTemp.end(); ++itr) {
			cout << *itr;
			if (itr < preorderTemp.end() - 1) cout << " ";
		}
		cout << endl;
	}
	if (root * 2 + 2 < N) { 
		if (BinayTree[root * 2 + 2] > BinayTree[root]) {
			MAXHEAP = false;
		}
		if (BinayTree[root * 2 + 2] < BinayTree[root]) {
			MINHEAP = false;
		}
		preOrderTRA(root * 2 + 2);
	}
	if (root * 2 + 1 < N) { 
		if (BinayTree[root * 2 + 1] > BinayTree[root]) {
			MAXHEAP = false;
		}
		if (BinayTree[root * 2 + 1] < BinayTree[root]) {
			MINHEAP = false;
		}
		preOrderTRA(root * 2 + 1); 
	}
	preorderTemp.pop_back();
}

int main() {
	MAXHEAP = true;
	MINHEAP = true;
	cin >> N;
	for (int i = 0; i < N; ++i) {
		cin >> BinayTree[i];
	}
	preOrderTRA(0);

	if (MAXHEAP && MINHEAP) {
		cout << "Not Heap" << endl;
		system("PAUSE");
		return 0;
	}

	if (MAXHEAP || MINHEAP) {
		if (MAXHEAP) {
			cout << "Max Heap" << endl;
		}
		if (MINHEAP) {
			cout << "Min Heap" << endl;
		}
	}
	else {
		cout << "Not Heap" << endl;
	}

	system("PAUSE");
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值