PAT-甲级-1122 Hamiltonian Cycle (25 分)

60 篇文章 0 订阅

1122 Hamiltonian Cycle (25 分)

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

解题思路:

  • 查询点数p = n+1;
  • 起点s = 终点d;
  • !!相邻点有连接边;
  •  无重复点数 = n;
     
#include <iostream>
#include <set>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
int v[210][210];
int main(){
    std::ios::sync_with_stdio(false);
    int n,m,k,a,b,p;
    cin>>n>>m;
    fill(v[0],v[0]+210*210,-1);
    rep(i,0,m){
        cin>>a>>b;
        v[a][b]=v[b][a]=1;
    }
    cin>>k;
    rep(i,0,k){
        int s,d,flag=1,pre;
        set<int> st;
        cin>>p>>pre;
        s = pre;
        rep(j,1,p){
            cin>>a;
            if(v[pre][a]!=1) flag=0;
            if(j==p-1)    d=a;
            st.insert(a);
            pre = a;
        }
        if(st.size()!=n || p != n+1 || s!=d || flag==0){
            cout<<"NO";
        }else cout<<"YES";
        if(i!=k-1)    cout<<"\n";
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值