1122 Hamiltonian Cycle-PAT甲级

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

满足哈密顿环的条件:(缺一不可)

  1. 必须能构成一个环
  2. 必须经过图中所有节点

      3.除了首尾这对相同结点可以出现2次外,其余节点在环中只能经过1次

 首先检查是否满足n+1个点,再检查是否除了首尾相同外,其余结点只出现过一次,再检查相邻两个结点是否存在路径

上述条件均满足输出YES,否则NO

满分代码如下:

#include<bits/stdc++.h>
using namespace std;
const int N=205;
int graph[N][N];
int dis[N];
int n,m,q;
int vst[N];

int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=n;j++)
			graph[i][j]=0;//初始化边 
	}
	for(int i=1;i<=m;i++){
		int x,y;
		cin>>x>>y;
		graph[x][y]=graph[y][x]=1;
	} 
	cin>>q;
	for(int i=1;i<=q;i++){
		int x;
		cin>>x;
		int flag=0;
		memset(vst,0,sizeof(vst));
		for(int j=1;j<=x;j++){
			cin>>dis[j];
	    }
	    if(x!=(n+1)){
			cout<<"NO"<<endl;
			continue;
		}
	    for(int j=1;j<=x;j++){
	    	if((vst[dis[j]]&&j!=x)||(vst[dis[j]]&&j==x&&dis[1]!=dis[j])){
				cout<<"NO"<<endl;
				flag=1;
				break;
			}
			if(j>1){
				if(!graph[dis[j-1]][dis[j]]){
					cout<<"NO"<<endl;
					flag=1;
					break;
				}
			}
			vst[dis[j]]=1;
		}
		if(flag) continue;
		cout<<"YES"<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值