PAT-1007. Maximum Subsequence Sum(最大连续子数列)

最大连续子数列的问题:

用了递归的解法,n长度的数列,先求得n-1的最大子数列,那么最大子数列要么是包含第n个数的数列,或者是不包含n的n-1的最大子数列。


Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. TheMaximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

代码存在问题:一个case超时,一个case错误.....

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main{
	
	public static class SubMax{
		int begin;
		int end;
		int sum;
	}
	public static List<Integer> allList;
	
	public static void main(String[] args) {
	
		//List<Integer> allList = new ArrayList<Integer>();
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		allList = new ArrayList<Integer>();
		for(int i = 0; i < n; i ++)
			allList.add(sc.nextInt());
		
		SubMax res = GetMaxSub(allList.size()-1);
		if(res.sum < 0)
		{
			res.sum = 0;
			res.begin = 0;
			res.end = allList.size()-1;
		}
		System.out.print(res.sum + " ");
		System.out.print(allList.get(res.begin) + " ");
		System.out.print(allList.get(res.end));
		
		sc.close();
	}
	
	public static SubMax GetMaxSub(int nEnd)
	{
		SubMax sub = new SubMax();
		if(nEnd == 0)
		{
			sub.begin = 0;
			sub.end = 0;
			sub.sum = allList.get(0);
			return sub;
		}
		SubMax sub2 = GetMaxSub(nEnd-1);
		
		int lastSum = 0;
		int lastBegin = 0;
		int tmpSum = 0;
		if(allList.get(nEnd) <= 0)
		{
			return sub2;
		}
		else
		{
			
			int i = nEnd;
			while(i >= 0)
			{
				tmpSum += allList.get(i);
				if(tmpSum > lastSum)
				{
					lastSum = tmpSum;
					lastBegin = i;
				}
				i = i - 1;
			}
			if(lastSum > sub2.sum)
			{
				sub2.sum = lastSum;
				sub2.begin = lastBegin;
				sub2.end = nEnd;
			}
		}
		return sub2;
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值