POJ3264——Balanced Lineup(线段树查询区间最大最小值)

Time limit
5000 ms
Case time limit
2000 ms
Memory limit
65536 kB


For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

InputLine 1: Two space-separated integers, N and Q. Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.



Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题解:

线段树建树加查询,只是树的每个节点要保存两个值(最大和最小),并且查询的时候返回结构体。

代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

const int MAXN = 50005;
const int INF = 0x3f3f3f3f;

int Tree[MAXN*4][2];
int Data[MAXN];

struct D{
	int MA;
	int MI;
	D(int a,int b){
		MA = a;
		MI = b;
	}
};

void Build(int temp,int left,int right){
	if(left == right){
		Tree[temp][0] = Tree[temp][1] = Data[left];
		return ;
	}
	int mid = left + (right-left)/2;
	Build(temp<<1,left,mid);
	Build(temp<<1|1,mid+1,right);
	Tree[temp][0] = max(Tree[temp<<1][0],Tree[temp<<1|1][0]);
	Tree[temp][1] = min(Tree[temp<<1][1],Tree[temp<<1|1][1]);
}

struct D query(int temp,int left,int right,int ql,int qr){
	if(ql>right || qr<left)return D(-INF,INF);
	if(ql<=left && qr>=right)return D(Tree[temp][0],Tree[temp][1]);	
	int mid = left + (right-left)/2;
	struct D a = query(temp<<1,left,mid,ql,qr);
	struct D b = query(temp<<1|1,mid+1,right,ql,qr);
	a.MA = max(a.MA,b.MA);
	a.MI = min(a.MI,b.MI);
	return a;
}

int main(){
	
	int N,M;
	scanf("%d %d",&N,&M);
	for(int i=1 ; i<=N ; i++)scanf("%d",&Data[i]);
	Build(1,1,N);
	int A,B;
	while(M--){
		scanf("%d %d",&A,&B);
		struct D t = query(1,1,N,A,B);
		printf("%d\n",t.MA-t.MI);
	}
	
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值