hdu 1867 A + B for you again(KMP灵活应用)

Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.

Input

For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.

Output

Print the ultimate string by the book.

Sample Input

asdf sdfg
asdf ghjk

Sample Output

asdfg
asdfghjk

题意:两个字符串A,B进行重合部分省略一边(例如 ABC+BC=ABC , ABC+BCD=ABCD,ABCD+BC=ABCDBC)的A+B和B+A得到两个串,然后输出其中较短的(长度相同时输出字典序最小的)。

题解:两个串互相KMP得到A+B和B+A各可以压缩多少字母,然后选择可以压缩的多的,相同的话比较字典序就行了。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int MAXN = 100005;

int _next[MAXN];
char s[MAXN],S[MAXN];

void getNext(char board[],int L){
    int k = -1;
    int j = 0;
    _next[0] = -1; 
    while(j<L){
        if(k == -1 || board[j] == board[k]){
            if(board[j+1] == board[k+1]){ 
                _next[++j] = _next[++k];
            }
            else _next[++j] = ++k;
        }
        else {
            k = _next[k];
        }
    }
}

int Find(char board[],char str[],int L1,int L2){//灵活运用点主要在这个函数
    getNext(board,L1);
    int temp1 = max(L2-L1,0),temp2 = 0;
    while(temp1<L2){
        if(temp2 == -1 || str[temp1] == board[temp2]){
            temp1++;temp2++;
        }
        else{
            temp2 = _next[temp2];
        }
    } 
    
    return temp2;
}

int main(){
	
	while(scanf("%s %s",s,S) != EOF){
		int a,b;
		a = Find(s,S,strlen(s),strlen(S));
		b = Find(S,s,strlen(S),strlen(s));
		//printf("#####%d %d  %d %d\n",a.ads,a.num,b.ads,b.num);
		if(a == b){
			if(strcmp(s,S) <= 0)printf("%s%s\n",s,S+b);
			else printf("%s%s\n",S,s+a);
		}
		else if(a < b)printf("%s%s\n",s,S+b);
		else  printf("%s%s\n",S,s+a);
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值