求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
Input
 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 
Output
 输出二叉树的先序遍历序列
Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
abdegcf
xnliu
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct bittree
{
    char data;
    struct bittree * l,* r;
};
struct bittree * create(int len,char * st1,char * st2)
{
    struct bittree * root;
    int i;
    if(len==0)
    {
        return NULL;
    }
    root=(struct bittree *)malloc(sizeof(struct bittree));
    root->data=st1[len-1];
    for(i=0;i<len;i++)
    {
        if(root->data==st2[i])
        {
            break;
        }

    }
    root->l=create(i,st1,st2);
    root->r=create(len-i-1,st1+i,st2+i+1);
    return root;
}
void houxu(struct bittree * p)
{
    if(p!=NULL)
    {
        printf("%c",p->data);
        houxu(p->l);
        houxu(p->r);
    }
}
int main()
{
    int len,n,i;
    char st1[99],st2[99];
    struct bittree * root;
    scanf("%d",&n);
    for(i=0;i<=n-1;i++)
    {
        scanf("%s %s",st2,st1);
        len=strlen(st1);
        root=create(len,st1,st2);
        houxu(root);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值