POJ-1582Ants(带翻译)

Ants

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 43063Accepted: 15694

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

一大群蚂蚁在一根长1厘米的水平杆上行走,每根都以1厘米/秒的恒定速度行走。当一只蚂蚁走到柱子的一端时,它会立即从柱子上掉下来。当两只蚂蚁相遇时,它们会掉头朝相反的方向行走。我们知道蚂蚁在北极的原始位置,不幸的是,我们不知道蚂蚁行走的方向。你的任务是计算所有蚂蚁从柱子上掉下来所需的最早和最晚时间。

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

输入的第一行包含一个整数,给出后面的事例数。每种情况下的数据都以两个整数开头:极点的长度(以厘米为单位)和n,即居住在极点上的蚂蚁数量。这两个数字后接n个整数,给出每个蚂蚁在极点上的位置,即从极点左端测得的距离,无特定顺序。所有输入的整数都不大于1000000,并用空格隔开。

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

对于输入的每种情况,输出两个用空格隔开的数字。第一个数字是所有蚂蚁从柱子上掉下来的最早时间(如果它们的行走方向选择得当),第二个数字是最晚可能的时间。

Sample Input(样例输入)

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output(样例输出)

4 8
38 207

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int x[100000],L,n;
void solve()
{
    int minT=0,maxT=0;
    for(int i=0;i<n;i++)
    {
        minT=max(minT,min(x[i],L-x[i]));
        maxT=max(maxT,max(x[i],L-x[i]));
    }
    cout<<minT<<" "<<maxT<<endl;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(x,0,sizeof(x));
        cin>>L>>n;
        for(int i=0;i<n;i++)
        cin>>x[i];
        solve();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值