HDU - 2846 - Repository(字典树)

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 5624    Accepted Submission(s): 1868


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 

Source
 

题目大意就是已知很多字符串,有多个询问,每个询问为一个字符串,问有多少个已知字符串中含有询问字符串

字典树,就是要把所有的都存了,要注意的是同一个字符串中多个相同字串不能多次计数。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<vector>
using namespace std;
int p,q,num[25];
char s[25];
struct node
{
    int be,cnt,num;
    vector<node*>next;
    node()//初始化
    {
        next.clear();
        be = -1;
        cnt = 0;
        num = 0;
    }
}*tree,*add;
int find_and_insert(node *now,int x,int len,int ope,int pos)
{
    if(x==len)
        return now->cnt;
    for(int i=0;i<now->next.size();i++)
    {
        if(now->next[i]->num!=num[x])
            continue;
        if(ope&&now->next[i]->be!=pos)
            now->next[i]->be = pos,now->next[i]->cnt++;//若该字串出现过且不在同一字符串中,则存在该字串的字符串个数加一
        return find_and_insert(now->next[i],x+1,len,ope,pos);
    }
    if(ope)//插入操作
    {
        node *add = new node;
        add->be = pos;
        add->num = num[x];
        add->cnt = 1;
        now->next.push_back(add);
        return find_and_insert(add,x+1,len,ope,pos);
    }
    else
        return 0;
}
void delete_tree(node *now)
{
    for(int i=0;i<now->next.size();i++)
        delete_tree(now->next[i]);
    delete now;
}
int main()
{
    tree = new node;
    add = new node;
    scanf("%d",&p);
    while(p--)
    {
        scanf("%s",s);
        for(int i=0;i<strlen(s);i++)
            num[i] = s[i] - 'a';
        for(int i=0;i<strlen(s);i++)
            find_and_insert(tree,i,(int)strlen(s),1,p);
    }
    scanf("%d",&q);
    while(q--)
    {
        scanf("%s",s);
        for(int i=0;i<strlen(s);i++)
            num[i] = s[i] - 'a';
        printf("%d\n",find_and_insert(tree,0,(int)strlen(s),0,q));
    }
    delete_tree(tree);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值