HDU-2846-Repository(字典树)

Repository

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4758 Accepted Submission(s): 1661

Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it’s length isn’t beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.

Sample Input
20
ad
ae
af
ag
ah
ai
aj
ak
al
ads
add
ade
adf
adg
adh
adi
adj
adk
adl
aes
5
b
a
d
ad
s

Sample Output
0
20
11
11
2

题意:给出模式串,给出子串,只要子串和模式串的一部分完全匹配就计数,输出数量

思路:模式串的所有后缀依次插入字典树,同时注意只有不同模式串的相同后缀才能计数,因此构造字典树时需要标记当前插入的后缀来自第几个模式串

代码

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
//字典树模板来一发
const int maxn=27;
struct Trie
{
    Trie *next[maxn];
    int num;
    int cent;//当前子串对应模式串编号
};
Trie root;
void Insert(char *str,int cent)
{
    Trie *p=&root,*q;
    int len=strlen(str);
    for(int i=0; i<len; i++)
    {
        int point=str[i]-'a';
        if(p->next[point]==NULL)
        {
            q=(Trie *)malloc(sizeof(Trie));
            q->num=1;
            q->cent=cent;
            for(int i=0; i<maxn; i++)
                q->next[i]=NULL;
            p->next[point]=q;
        }
        else if(p->next[point]->cent!=cent)//防止重复计数同一模式串的后缀
        {
            p->next[point]->num++;
            p->next[point]->cent=cent;
        }
        p=p->next[point];
    }
}
int Result(char *str)
{
    Trie *p=&root;
    int len=strlen(str);
    for(int i=0; i<len; i++)
    {
        int point=str[i]-'a';
        if(p->next[point]==NULL)
            return 0;
        p=p->next[point];
    }
    return p->num;
}
int main()
{
    int T;
    while(scanf("%d",&T)!=EOF)
    {
        root.num=0;
        root.cent=-1;
        for(int i=0; i<maxn; i++)
            root.next[i]=NULL;
        for(int casen=1;casen<=T;casen++)
        {
            char str[maxn];
            memset(str,'\0',sizeof(str));
            scanf("%s",str);
            int len=strlen(str);
            char flag[maxn];
            for(int i=0; i<len; i++)
            {
                memset(flag,'\0',sizeof(flag));
                for(int j=i,k=0; j<len; j++,k++)
                    flag[k]=str[j];
                Insert(flag,casen);//后缀全部插入字典树
            }
        }
        scanf("%d",&T);
        while(T--)
        {
            char str[maxn];
            memset(str,'\0',sizeof(str));
            scanf("%s",str);
            printf("%d\n",Result(str));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值