POJ 1743 Musical Theme (后缀数组)

Musical Theme

Time Limit: 1000MS Memory Limit: 30000K
Description

A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings.
Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it:
is at least five notes long
appears (potentially transposed – see below) again somewhere else in the piece of music
is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

Transposed means that a constant positive or negative value is added to every note value in the theme subsequence.
Given a melody, compute the length (number of notes) of the longest theme.
One second time limit for this problem’s solutions!
Input

The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes.
The last test case is followed by one zero.
Output

For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.
Sample Input

30
25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
82 78 74 70 66 67 64 60 65 80
0
Sample Output

5
Hint

Use scanf instead of cin to reduce the read time.

题目大意:
有N(1 <= N <=20000)个音符的序列来表示一首乐曲,每个音符都是1..88范围内的整数,现在要找一个重复的主题。“主题”是整个音符序列的一个子串,它需要满足如下条件:
1.长度至少为5个音符。
2.在乐曲中重复出现。(可能经过转调,“转调”的意思是主题序列中每个音符都被加上或减去了同一个整数值)
3.重复出现的同一主题不能有公共部分。

思路:
因为判断重复是以趋势相同,所以考虑求出相邻音符的差值,然后把问题转化为不可重叠最长重复子串,用后缀数组来做。
先二分长度k,判断是否存在两个长度为k的子串是相同的,且不重叠。
把排序后的后缀分成若干组,其中每组的后缀之间的height值都不小于k。不在同一个分组里面的后缀的公共前缀长度一定达不到k。
要在每个分组里面找不重叠的子串,那么就维护这个区间里面起始位置最大的差值,差值如果大于k,才没有重叠。

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define LL long long
#define N 20005
using namespace std;

int t1[N], t2[N], c[N], sa[N];  
int rank[N], height[N], s[N]; 
int ans, n, m, mx;

void build_sa(int m){
    int *x = t1, *y = t2;
    for(int i=0; i<m; i++) c[i] = 0;
    for(int i=0; i<n; i++) c[x[i] = s[i]]++;
    for(int i=1; i<m; i++) c[i] += c[i-1];
    for(int i=n-1; i>=0; i--) sa[--c[x[i]]] = i;
    for(int k=1; k<=n; k = k<<1){
        int p = 0;
        for(int i=n-k; i<n; i++) y[p++] = i; 
        for(int i=0; i<n; i++) if(sa[i] >= k) y[p++] = sa[i]-k;
        for(int i=0; i<m; i++) c[i] = 0;
        for(int i=0; i<n; i++) c[x[y[i]]]++;
        for(int i=0; i<m; i++) c[i] += c[i-1];
        for(int i=n-1; i>=0; i--) sa[--c[x[y[i]]]] = y[i];
        swap(x,y);
        p = 1; x[sa[0]] = 0;
        for(int i=1; i<n; i++)
            x[sa[i]] = y[sa[i-1]] == y[sa[i]] && y[sa[i-1]+k] == y[sa[i]+k] ? p-1 : p++;
        if(p >= n) break;
        m = p; 
    }
}

void build_height(int *r, int n){
    int k=0, j;  
    for(int i=1; i<=n; i++) rank[sa[i]] = i;//最后补上了0 
    for(int i=0; i<n; height[rank[i++]] = k)
        for(k ? k--:0, j = sa[rank[i]-1]; r[i+k] == r[j+k]; k++);
}  

int check(int k){  
    int maxx, minn;//维护满足条件的最靠前和最靠后的两个位置 
    maxx = minn = sa[1];  
    for(int i=2; i<=n; i++){
        if(height[i]>=k && i<n){  
            minn = min(minn, sa[i]);  
            maxx = max(maxx, sa[i]);  
            continue;  
        }
        if(maxx - minn >= k) return 1;//位置差超过k,那么就一定存在一个长度为k,且不会有交集的答案 
        maxx = minn = sa[i];//重新分组 
    }
    return 0;  
}

int main(){
    while( (~scanf("%d", &n), n) ){  
        for(int i=0; i<=n-1; i++) scanf("%d", &s[i]);  
        for(int i=0; i<=n-2; i++) s[i] = s[i+1] - s[i] + 88/*转为正数*/;
        //因为可以同加同减,所以只需要维护差值 
        s[n-1] = 0;//在末尾补上0 
        build_sa( 180 ); n--; 
        build_height(s, n); 
        int l = 4, r = n;
        int ans = 0;
        while(l <= r){  
            int mid = (l + r) >> 1;  
            if( check( mid ) ){  
                ans = mid;  
                l = mid + 1;  
            }  
            else r = mid - 1;  
        }  
        ans++;  
        printf("%d\n", ans<5 ? 0 : ans);
    }
    return 0;  
}  
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值