hdu 1880

魔咒词典

Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14661 Accepted Submission(s): 3528

Problem Description
哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”

Input
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

Output
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”

Sample Input
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

Sample Output
light the wand
accio
what?
what?

Author
ZJU

Source
浙大计算机研究生复试上机考试-2008年

字符串Hash

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#define MAXN 100010
#define mod 100007
#define inf 0x7fffffff
struct node
{
    char s1[30];
    char s2[90];
    int next;
}nodeA[MAXN],nodeB[MAXN];
int curA,curB;
int hashTableA[MAXN],hashTableB[MAXN];
void initHash()
{
    memset(hashTableB,-1,sizeof(hashTableB));
    memset(hashTableA,-1,sizeof(hashTableA));
    curA = 0;
    curB = 0;
}
int getHash(char *s)
{
    int seed = 131;
    int hash = 0;
    while(*s)
    {
        hash = hash*seed + *s++;
    }
    return (hash & inf) % mod;
}
void insertHash(char *s1, char *s2)
{
    int h;
    h = getHash(s1);
    strcpy(nodeA[curA].s1,s1);
    strcpy(nodeA[curA].s2,s2);
    nodeA[curA].next = hashTableA[h];
    hashTableA[h] = curA;
    curA++;
    h = getHash(s2);
    strcpy(nodeB[curB].s1,s1);
    strcpy(nodeB[curB].s2,s2);
    nodeB[curB].next = hashTableB[h];
    hashTableB[h] = curB;
    curB++;
}
int searchHashA(char *s)
{
    int h = getHash(s);
    int next = hashTableA[h];
    while(next != -1)
    {
        if(strcmp(s,nodeA[next].s1) == 0) return next;
        next = nodeA[next].next;
    }
    return -1;
}
int serchHashB(char *s)
{
    int h = getHash(s);
    int next = hashTableB[h];
    while(next != -1)
    {
        if(strcmp(s,nodeB[next].s2) == 0) return next;
        next = nodeB[next].next;
    }
    return -1;
}
int main()
{
    initHash();
    char str[105];
    char s1[30],s2[90];
    while(gets(str))
    {
        if (str[0] == '@') break;
        int p1 = 0,p2 = 0;
        int len = strlen(str);
        if(str[0] == '[')
        {
            for(int i = 1; str[i] != ']'; i++)
            {
                s1[p1++] = str[i];
            }
            s1[p1] = 0;
            for(int i = p1+3; str[i] != 0; i++)
            {
                s2[p2++] = str[i];
            }
            s2[p2] = 0;
            insertHash(s1,s2);
        }
    }
    int n;
    char ss[90];
    scanf("%d\n",&n);
    int ans;
    for(int i = 0; i < n; i++)
    {
        gets(ss);
        int hss = strlen(ss);
        if(ss[0] == '[')
        {
            ss[hss-1] = 0;
            ans = searchHashA(ss+1);
            if(ans == -1) printf("what?\n");
            else          printf("%s\n",nodeA[ans].s2);
        }
        else
        {
            ans = serchHashB(ss);
            if(ans == -1) printf("what?\n");
            else          printf("%s\n",nodeB[ans].s1);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值