Hie with the Pie POJ - 3311

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

题意:有n个点,从0号点出发,将1-n-1个点都走一遍并且回到0点(每个点不限制走的次数),给出每个点间的距离,求出最小的路径花费。

整体思路:

将环转化为线,min{ 0出发走遍所以点的代价+最后一个点到0的距离}

需要3个信息:

1、已经走过的点集合(用int状态压缩表示)

2、当前站在哪个点

3、找到下一个点。

所以开一个数组,dp[1<<n][n],dp[i][j]表示当前走过的点集合是i,当前站在j点上。

i---->int,如  6 是(110),表示已经走了第1,2个点,1表示该位置的点已经走过。

 

中间还需要一个二位数组m求出任意两点的最短距离,使用floyed法。

#include<iostream>
#include<cstring>
using namespace std;

//基于集合的动态规划
int n,m[12][12],dp[1<<12][12];//dp[i][j]表示已经走过的集合状态为i,并且以j点结束

void check(int&x,int y){//更新值,注意-1也可以更新
    if(x==-1 ||x>y)
        x=y;
}
int main()
{
    while(cin>>n&&n){
        n++;
        for(int i=0; i<n; i++){
           for(int j=0; j<n;j++){
                cin>>m[i][j];
           }
        }
        //求任意两个点的最短距离floyed
        for(int k=0; k<n; k++){//间断点
            for(int i=0; i<n; i++){//开始点
                for(int j=0; j<n; j++){//终点
                    if(m[i][j]>m[i][k]+m[k][j])
                        m[i][j]=m[i][k]+m[k][j];
                }
            }
        }
        memset(dp,-1,sizeof(dp));
        dp[1][0]=0;//初始状态,当前站在第0个点,并且1以0结束
        for(int mask=1;mask<(1<<n);mask++){//已经走过的集合
            for(int end=0; end<n; end++){//结束的点
                if(dp[mask][end]!=-1)//枚举一个求好的状态
                {
                    for(int nxt=0; nxt<n; nxt++){//下一个点
                        if(!(mask&(1<<nxt))){//假如nxt没有走过
                            check(dp[mask|(1<<nxt)][nxt],dp[mask][end]+m[end][nxt]);
                        }
                    }
                }
            }
        }
        int ans=-1;
        for(int end=0; end<n; end++){
            check(ans,dp[(1<<n)-1][end]+m[end][0]);
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值