HDU 1711 - Number Sequence (KMP)

49 篇文章 0 订阅
7 篇文章 0 订阅

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

题意:

      给你两个数组a,b,问是否存在一个m使得a[m]=b[1],a[m+1]=b[2].....。输出最小的m,如果不存在的话,输出-1。

思路:

     这题的意思其实就是判断在b串在a串的哪个位置出现,包含在a串中。就用kmp模板然后,当b串搜索结束后,输出a串中当前位置i - q(b串长度)+1即可(因为i是a串现在所处的位置,q为b串长度,我从0开始读入的,如果从i = 1读入就不需要加1了)。

代码:

#include<stdio.h>
#include<string.h>
int a[1000010],b[10010];
int next[10010];
int n,p,q;
void get_next()
{
	int i,j;
	i=1;
	j=0;
	while(i<q)
	{
		if(j==0&&b[i]!=b[j])
		{
			next[i]=0;
			i++;	
		}
		else if(j>0&&b[i]!=b[j])
		{
			j=next[j-1];
		}
		else
		{
			next[i]=j+1;
			i++;
			j++;
		}
	}
}
int kmp()
{
	int i,j,flag=0;
	i=0;
	j=0;
	while(i<p&&j<q)
	{
		if(j==0&&a[i]!=b[j])
		{
			i++;
		}
		else if(j>0&&a[i]!=b[j])
		{
			j=next[j-1];
		}
		else
		{
			i++;
			j++;
		}
	}
	if(j>=q)                       //当b串搜索完
		printf("%d\n",i+1-q);  //因为i是a串现在所处的位置,q为b串长度
	else
		printf("-1\n");
 } 
int main()
{
	int i;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&p,&q);
		for(i=0;i<p;i++)
			scanf("%d",&a[i]);
		for(i=0;i<q;i++)
			scanf("%d",&b[i]);
		get_next();
		kmp();
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值