Poj 3259 Wormholes ( SPFA&&bellman-ford

Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

题意

真是迷之题意mdezz 到最后 给了几个负权值 问怎么跑的比较快(时间倒流) 蛤?

题解:

spfa判断负环是否存在

AC代码

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;

#define LL long long
#define CLR(a,b) memset(a,(b),sizeof(a))

const int INF = 0x3f3f3f3f;
const LL INFLL = 0x3f3f3f3f3f3f3f3f;
const int N = 2e5+10;
vector<pair<int,int> > G[N];
int dis[N];
int cnt[N];
bool vis[N];
int n, m, w;
void init()
{
    CLR(cnt,0);
    CLR(vis,false);
    for(int i = 0; i < N; i++) G[i].clear();
    for(int i = 0; i < N; i++) dis[i] = INF;
}
bool spfa(int s)
{
    queue<int> q;
    dis[s] = 0; q.push(s); vis[s] = true; cnt[s] = 1;
    while(!q.empty()) {
        int u = q.front(); q.pop();
        vis[u] = false;
        for(int i = 0;i < G[u].size(); i++) {
            int t = G[u][i].first;
            if(dis[t] > dis[u]+G[u][i].second) {
                dis[t] = dis[u]+G[u][i].second;
                if(!vis[t]) {
                    cnt[t]++;
                    if(cnt[t] >= n) return true;
                    vis[t] = true;
                    q.push(t);
                }
            }
        }
    }
    return false;
}
int main()
{
    //freopen("out.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--) {
        scanf("%d%d%d",&n,&m,&w);
        init();
        int x, y, z;
        for(int i = 0;i < m; i++) {
            scanf("%d%d%d",&x,&y,&z);
            G[x].push_back(make_pair(y,z));
            G[y].push_back(make_pair(x,z));
        }
        for(int i = 0; i < w; i++) {
            scanf("%d%d%d",&x,&y,&z);
            G[x].push_back(make_pair(y,-z));
        }
        if(spfa(1)) puts("YES");
        else puts("NO");
    }
return 0;
}

bellman-ford

#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN =5e3+10;
int dis[MAXN];
struct edge
{
    int u, v, cost;
    edge(int _u=0, int _v=0, int _cost=0):u(_u),v(_v),cost(_cost){}

};
vector<edge> E;
bool bellman_ford(int s,int n)
{
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[s] = 0;
    for(int i = 0; i < n; i++) {
        bool flag = false;
        for(int j = 0; j < E.size(); j++) {
            int u = E[j].u;
            int v = E[j].v;
            int cost = E[j].cost;
            if(dis[v] > dis[u]+cost) {
                dis[v] = dis[u]+cost;
                flag = true;
            }

        }
        if(!flag) return true;
    }
    for(int i = 0; i < E.size(); i++) {
        int u = E[i].u;
        int v = E[i].v;
        int cost = E[i].cost;
        if(dis[v] > dis[u]+cost)
            return false;
    }
    return true;
}
int main()
{
    ios::sync_with_stdio(false),cin.tie(0);
    int T;
    int n, m, w;
    int a, b, c;
    cin >> T;
    while(T--) {
        E.clear();
        cin >> n >> m >> w;
        for(int i = 0; i < m; i++) {
            cin >> a >> b >> c;
            E.push_back(edge{a,b,c});
            E.push_back(edge{b,a,c});
        }
        for(int i = 0; i < w; i++) {
            cin >> a >> b >> c;
            E.push_back(edge{a,b,-c});
        }
        for(int i = 1; i <= n; i++)
            E.push_back(edge{n+1,i,0});
        if(!bellman_ford(n+1,n+1))
            cout << "YES\n";
        else
            cout << "NO\n";

    }

return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值