The Accomodation of Students

Problem Description
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.
 

Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
 

Sample Output
  
  
No 3 题解:先判断是否能存在将m对人放在两个房间,并且每个房间的人互相不认识,这就是二分图的判定了。如果存在,再求最大匹配。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

bool map[1003][1003];
int color[1003];
bool visited[1003];
int pre[1003];

int max(int a,int b)
{
	return a > b ? a : b;
}

bool dfs(int x,int n)
{
	for(int i = 1;i <= n;i++) //在相邻边找匹配点,其实每次就是找一个pre为0的点,该点没有匹配过。
	{
		if(map[x][i])
		{
			if(!visited[i])  //不能往回找
			{
				visited[i] = true;
				if(pre[i] == 0 || dfs(pre[i],n))
				{
					pre[i] = x;  //反转,这样就多了一条边了,因为又找到了一个没有匹配的点
					return true;
				 } 
			}
		}
	}
	
	return false;
}

bool find(int x,int n)
{
	for(int i = 1;i <= n;i++)
	{
		if(map[x][i])
		{
			if(color[i] == 0)
			{
				color[i] = 3 - color[x];
				if(!find(i,n))
				{
					return false;
				}
			}
			else if(color[i] == color[x])  //矛盾,既认识又不认识
			{
				return false;
			}
		}
	}
	
	return true;
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m) != EOF)
	{
		int u,v;
		memset(map,false,sizeof(map));
		memset(color,0,sizeof(color));
		memset(pre,0,sizeof(pre));
		for(int i = 0;i < m;i++)
		{
			scanf("%d%d",&u,&v);
			map[u][v] = map[v][u] = true;
		}
		
		bool flag = true;
		for(int i = 1;i <= n;i++)
		{
			if(color[i] == 0)
			{
				color[i] = 1;
				if(!find(i,n))
				{
					flag = false;
					break;
				}
			}
		}
		
		int ans = 0;
		if(flag)
		{
			for(int i = 1;i <= n;i++)
			{
				memset(visited,false,sizeof(visited));
				if(dfs(i,n))
				{
					ans++;
				}
			}
			printf("%d\n",ans / 2);       //找了两次,主要是map[u][v]和map[v][u]都是true,如果只有一个,找两次也没有用就不除2
		}
		else
		{
			printf("No\n");
		}
	}
	
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值