A Simple Problem with Integers

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


题解:线段树延迟做法,就是延迟对孩子节点的操作,把前面要操作的数据记录下来,等下次必须访问孩子的时候才去做,减少递归次数。

#include <iostream>
#include <cstdio>
#include <cstring>
#define mem(a) memset(a,0,1izeof(a));

using namespace std;

long long arr[400005];
long long add[400005];
long long a[100005];

void pushUp(int k)
{
	arr[k] = arr[k << 1] + arr[(k << 1) | 1];
}

void pushDown(int k,int x)    //分给左右孩子。
{
	if(add[k] != 0)
	{
		add[k << 1] += add[k];
		add[(k << 1) | 1] += add[k];
		arr[k << 1] += add[k] * (x - (x >> 1));
		arr[(k << 1) | 1] += add[k] * (x >> 1);
		add[k] = 0; 
	}
}

void segTree(int k,int l,int r)
{
	add[k] = 0;
	if(l == r)
	{
		arr[k] = a[l];
		return;
	}
	int mid = ( l + r) >> 1;
	segTree(k << 1,l,mid);
	segTree((k << 1) | 1,mid + 1,r);
	pushUp(k);
}

void update(int k,int l,int r,int x,int y,int c)
{
	if(l == x && r == y)
	{
		add[k] += c;
		arr[k] += (r - l + 1) * c;
		return;
	}
	int mid = (l + r) >> 1;
	pushDown(k,r - l + 1);
	if(x > mid)
	{
		update((k << 1) | 1,mid + 1,r,x,y,c);
	}
	else if(y <= mid)
	{
		update(k << 1,l,mid,x,y,c);
	}
	else
	{
		update(k << 1,l,mid,x,mid,c);
		update((k << 1) | 1,mid + 1,r,mid + 1,y,c);
	}
	pushUp(k);
}

long long query(int k,int l,int r,int x,int y)
{
	if(l == x && r == y)
	{
		return arr[k];
	}
	pushDown(k,r - l + 1);
	int mid = (l + r) >> 1;
	if(x > mid)
	{
		return query((k << 1) | 1,mid + 1,r,x,y);
	}
	if(y <= mid)
	{
		return query(k << 1,l,mid,x,y);
	}
	return query(k << 1,l,mid,x,mid) + query((k << 1) | 1,mid + 1,r,mid + 1,y);
}

int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m) != EOF)
	{
		for(int i = 1;i <= n;i++)
		{
			scanf("%lld",a + i);
		}
		
		segTree(1,1,n);
		char s[3];
		int l,r;
		for(int i = 0;i < m;i++)
		{
			scanf("%s%d%d",s,&l,&r);
			if('Q' == s[0])
			{
				printf("%lld\n",query(1,1,n,l,r));
			}
			else
			{
				long long c;
				scanf("%lld",&c);
				update(1,1,n,l,r,c);
			}
		}
	}
	
	
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Here is a C++ program that constructs a max heap with integers and prints it in the rotated form: ```cpp #include <iostream> #include <vector> using namespace std; // function to swap two integers void swap(int& a, int& b) { int temp = a; a = b; b = temp; } // function to heapify the given vector void heapify(vector<int>& arr, int n, int i) { int largest = i; // initialize largest as root int left = 2*i + 1; // left child index int right = 2*i + 2; // right child index // if left child is larger than root if (left < n && arr[left] > arr[largest]) largest = left; // if right child is larger than largest so far if (right < n && arr[right] > arr[largest]) largest = right; // if largest is not root if (largest != i) { // swap the root with largest element swap(arr[i], arr[largest]); // recursively heapify the affected sub-tree heapify(arr, n, largest); } } // function to build max heap void buildMaxHeap(vector<int>& arr, int n) { // start from the last non-leaf node and heapify each node for (int i = n / 2 - 1; i >= 0; i--) heapify(arr, n, i); } // function to print the heap in the rotated form void printRotatedHeap(vector<int>& arr, int n) { int height = log2(n) + 1; // height of the heap int index = 0; // current index in the heap int spaces = pow(2, height - 1) - 1; // number of spaces before the first element of the current level // print each level of the heap in the rotated form for (int i = 0; i < height; i++) { // print the spaces before the first element of the current level for (int j = 0; j < spaces; j++) cout << " "; // print the elements of the current level for (int j = 0; j < pow(2, i) && index < n; j++) { cout << arr[index++] << " "; // print the spaces between elements of the current level for (int k = 0; k < 2 * spaces + 1; k++) cout << " "; } // move to the next line and adjust the number of spaces for the next level cout << endl; spaces /= 2; } } int main() { int n; cout << "Enter the number of elements: "; cin >> n; vector<int> arr(n); cout << "Enter the elements: "; for (int i = 0; i < n; i++) cin >> arr[i]; // build max heap buildMaxHeap(arr, n); // print the heap in the rotated form cout << "Max heap in the rotated form:\n"; printRotatedHeap(arr, n); return 0; } ``` In this program, we first define a `swap` function to swap two integers, and a `heapify` function to heapify the sub-tree rooted at a given index `i` in the given vector `arr`. We then define a `buildMaxHeap` function to build the max heap from the given vector `arr`. Finally, we define a `printRotatedHeap` function to print the max heap in the rotated form. In the `main` function, we first read the number of elements and the elements themselves from the user using `cin`. We then build the max heap using `buildMaxHeap` function, and print the heap in the rotated form using `printRotatedHeap` function. The `printRotatedHeap` function uses the height of the heap to determine the number of levels, and the number of spaces before the first element of each level. It then prints each level of the heap in the rotated form, by printing the elements of the level followed by the spaces between elements.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值