[Usaco2007 Demo]City skyline

Description

Input

第一行给出 N N W
第二行到第 N+1 N + 1 行:每行给出二个整数 x,y x , y ,输入的 x x 严格递增,并且第一个x总是 1 1

Output

输出一个整数,表示城市中最少包含的建筑物数量

Sample Input

10 26
1 1
2 2
5 1
6 3
8 1
11 0
15 2
17 3
20 2
22 1

INPUT DETAILS:

The case mentioned above

Sample Output

6

HINT

Source

Silver

思路

单调栈维护高度,插入一个数,如果栈顶比他大那么弹出栈顶并且答案加1;如果栈顶与他相同那么弹出栈顶。

代码

#include <cstdio>

const int maxn=50000;

struct stack
{
  int s[maxn+10],head;

  inline int push(int x)
  {
    s[++head]=x;
    return 0;
  }

  inline int pop()
  {
    --head;
    return 0;
  }

  inline int top()
  {
    return s[head];
  }

  inline int size()
  {
    return head;
  }
};

stack st;
int ans,n,w,a,b;

int main()
{
  scanf("%d%d",&n,&w);
  while(n--)
    {
      scanf("%d%d",&a,&b);
      while(st.size()&&(st.top()>b))
        {
          st.pop();
          ++ans;
        }
      while(st.size()&&(st.top()==b))
        {
          st.pop();
        }
      if(b)
        {
          st.push(b);
        }
    }
  ans+=st.size();
  printf("%d\n",ans);
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值