Background

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions. Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input
1
3 3
1 2 3
1 3 4
2 3 5
Sample Output
Scenario #1:
4
题目大意是就是何处一个图,n个顶点和m条边,每个边都有最大承载量,现在我要从1点运送货物到n点,求能运送货物的最大重量。
对于数据,第一行为t代表测试数据个数,第二行为n和m(意义见上),接着m行,每行三个整数分别是代表一条边的起点,终点及最大承重量。输出能运送货物的最大重量。注意两个换行
样例解释:
方案1:1-2-3,其中1-2承重为3,2-3承重为5,则可以运送货物的最大重量是3(当大于3时明显1到不了2)
方案2:1-3,可知1-3承重为4,故此路可运送货物的最大重量是4,故答案输出4
想法:Kruscal算法最小生成树改变, n个点,m条边,求一条最大的边中,载物承受能力最小的,,否则找大的会把载物能力小的桥压塌(和桥限重一样)
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define spot 100000
#define edge 1000000
struct stu
{
    int x,y,z;
} a[edge+10];
int b[spot+10];
bool cmp(stu a,stu b)
{
    return a.z>b.z;
}
int finds(int x)
{
    int j,d=x;
    while(x!=b[x])
        x=b[x];
    while(b[d]!=x)//并查集路径压缩
        j=d,d=b[d],b[j]=x;
    return x;
}
bool mix(int x,int y)
{
    int fx=finds(x),fy=finds(y);
    if(fx!=fy)
    {
        return 0;
    }
    return 1;
}
int main()
{
    int n,m,i;
    int t;
    scanf("%d",&t);
    int g=0;
    while(t--)
    {
        ++g;
        scanf("%d%d",&n,&m);
        int sum=10000000,s=10000000;
        for(i=1; i<=n; i++)
            b[i]=i;
        for(i=1; i<=m; i++)
            scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].z);
        sort(a+1,a+m+1,cmp);//把边从大到小排下序
        printf("Scenario #%d:\n",g);
        for(i=1; i<=m; i++)
        {
            if(!mix(a[i].x,a[i].y))
            {
                b[finds(a[i].x)]=finds(a[i].y);
                sum=min(sum,a[i].z);
                if(mix(1,n)==1)//当前的路从1到n可以通行,那么这条路找的sum最小的载重量就是答案
                    break;
            }
        }
        printf("%d\n\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值