Wow! Such City!

Doge, tired of being a popular image on internet, is considering moving to another city for a new way of life.
In his country there are N (2 ≤N≤ 1000) cities labeled 0 . . . N - 1. He is currently in city 0. Meanwhile, for each pair of cities, there exists a road connecting them, costing C i, j (a positive integer) for traveling from city i to city j. Please note that C i, j may not equal to C j, i for any given i ≠ j.
Doge is carefully examining the cities: in fact he will divide cities (his current city 0 is NOT included) into M (2 ≤ M ≤ 10 6) categories as follow: If the minimal cost from his current city (labeled 0) to the city i is Di, city i belongs to category numbered Di mod M.Doge wants to know the “minimal” category (a category with minimal number) which contains at least one city.
For example, for a country with 4 cities (labeled 0 . . . 3, note that city 0 is not considered), Doge wants to divide them into 3 categories. Suppose category 0 contains no city, category 1 contains city 2 and 3, while category 2 contains city 1, Doge consider category 1 as the minimal one.
Could you please help Doge solve this problem?

Note:

C i, j is generated in the following way:
Given integers X 0, X 1, Y 0, Y 1, (1 ≤ X 0, X 1, Y 0, Y 1≤ 1234567), for k ≥ 2 we have
Xk  = (12345 + X k-1 * 23456 + X k-2 * 34567 + X k-1 * X k-2 * 45678)  mod  5837501
Yk  = (56789 + Y k-1 * 67890 + Y k-2 * 78901 + Y k-1 * Y k-2 * 89012)  mod  9860381
The for k ≥ 0 we have

Z k = (X k * 90123 + Y k ) mod 8475871 + 1

Finally for 0 ≤ i, j ≤ N - 1 we have

C i, j = Z i*n+j for i ≠ j
C i, j = 0   for i = j
Input
There are several test cases. Please process till EOF.
For each test case, there is only one line containing 6 integers N,M,X 0,X 1,Y 0,Y 1.See the description for more details.
Output
For each test case, output a single line containing a single integer: the number of minimal category.
Sample Input
3 10 1 2 3 4
4 20 2 3 4 5
Sample Output
1
10

For the first test case, we have


	   0	   1	   2	   3	   4	   5	   6	   7	   8
X	   1	   2	 185180	 788997	1483212	4659423	4123738	2178800	 219267
Y	   3	   4	1633196	7845564	2071599	4562697	3523912	317737	1167849
Z	 90127	 180251	1620338	2064506	 625135	5664774	5647950	8282552	4912390

the cost matrix C is
	         	   0	 180251	1620338
	                2064506	   0	5664774
	                5647950	8282552	   0


        
  
Hint

So the minimal cost from city 0 to city 1 is 180251, while the distance to city 2 is 1620338.Given M = 10, city 1 and city 2 belong to category 1 and 8 respectively.Since only category 1 and 8 contain at least one city,the minimal one of them, category 1, is the desired answer to Doge’s question.


先根据式子把矩阵算出来,然后迪杰斯特拉跑一遍找0到1,2,3,,,n-1的最短路径,最后找这些路径%m的最小值就行了
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
long long int vis[1010];
long long int dis[1010];
long long int a[1002000];
long long int b[1002000];
long long int c[1002000];
long long int we[1010][1010];
long long int min(long long int a,long long int b)
{
    if(a>b)
        return b;
    else
        return a;
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        int x,y,x1,y1;
        scanf("%d%d%d%d",&x,&x1,&y,&y1);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        a[0]=x;
        a[1]=x1;
        b[0]=y;
        b[1]=y1;
        memset(we,0,sizeof(we));
        c[0]=(a[0]*90123 +b[0])%8475871 + 1;
        c[1]=(a[1]*90123 +b[1])%8475871 + 1;
        for(int i=2;i<=n*n;i++)
        {
            a[i]=(12345+ a[i-1]*23456+a[i-2]*34567 + a[i-1] * a[i-2]* 45678)%5837501;
            b[i]=(56789 + b[i-1]* 67890 + b[i-2] * 78901 + b[i-1] * b[i-2]* 89012)%9860381;
            c[i]=(a[i]*90123 +b[i])%8475871 + 1;
        }
        memset(we,0x3f3f3f3f,sizeof(we));
        for(int i=0;i<n;i++)
        {
            we[i][i]=0;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(i!=j)
                {
                    we[i][j]=c[i*n+j];
                }
                if(i==j)
                {
                    we[i][j]=0;
                }
            }
        }
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)
        {
            dis[i]=we[0][i];
        }
        vis[0]=1;
        for(int i=0;i<n;i++)
        {
            long long int minn=0x3f3f3f3f;
            int u;
            for(int j=0;j<n;j++)
            {
                if(dis[j]<minn&&!vis[j])
                {
                    u=j;
                    minn=dis[j];
                }
            }
            vis[u]=1;
            for(int j=0;j<n;j++)
            {
                if(dis[j]>minn+we[u][j]&&we[u][j]<0x3f3f3f3f)
                {
                    dis[j]=minn+we[u][j];
                }
            }
        }
        long long int minnn=0x3f3f3f3f;
        for(int i=1;i<n;i++)
        {
            minnn=min(minnn,dis[i]%m);
        }
        printf("%lld\n",minnn);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值