Goldbach`s Conjecture

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

Hint

1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

题意:让你找出两个素数相加等于n的对数

按照常规的思路是必须Memory Limit,,,所以我们就可以把数组写成bool型的,因为int是4个字节,bool是一个字节。

然后改完交,,理所当然的TLE。。。。。。再改。。。之后我们就想我们可以把第几个素数的用数组记录下来,10000000里内的素数的个数肯定是<10000000/2的。。这样我们在挨个询问素数的时候是不是时间就少了。这样就AC了

#include<stdio.h>
#include<string.h>
bool a[10000001];
int b[666666];
int p=0;
void we()
{
    memset(a,false,sizeof(a));
    a[0]=a[1]=true;
    for(int i=2; i<=10000000; i++)
    {
        if(!a[i])
        {
            b[p++]=i;
            for(int j=2*i; j<=10000000; j+=i)
                a[j]=true;
        }

    }
}
int main()
{
    we();
    int t;
    scanf("%d",&t);
    int g=0;
    while(t--)
    {
        ++g;
        int n;
        scanf("%d",&n);
        int sum=0;
        for(int i=0; i<p; i++)
        {
            if(b[i]>=n/2+1)
                break;
           if(!a[n-b[i]]&&n>=2*b[i])
           {
               sum++;
           }
        }
        printf("Case %d: %d\n",g,sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值