Trailing Zeroes (III)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

题意:让你找出一个最小的a!的值中末尾的0的个数为n的数

思路:二分,因为末尾0的个数和5有关,所以每次找一个值都要看它的0是不是等于n

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL long long
LL chazhao(LL n)//找出n!的末尾的0的个数
{
    LL cnt=0;
    while(n>=5)
    {
        cnt+=n/5;
        n=n/5;
    }
    return cnt;
}
LL fun(LL n)
{
    LL mind,left=0,right=500000000;//N!的结尾最多有1*10^8个0,因而high=500000000足够了。
    while(left<=right)
    {
        mind=(left+right)/2;
        if(chazhao(mind)>n)
        {
            right=mind-1;
        }
        else
            left=mind+1;
    }
    right=right-(right%5);//把*转化,当前求得的right值,不是题目所要求的(满足限制条件:0的个数)最小数字,所以我们要把余数给减去才是最小的数
    if(chazhao(right)==n)
        return right;
    else
        return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    int g=0;
    while(t--)
    {
        ++g;
        LL n;
        scanf("%lld",&n);
        LL k=fun(n);
        if(k!=0)
        {
            printf("Case %d: %lld\n",g,k);
        }
        else
        {
            printf("Case %d: ",g);
            printf("impossible\n");
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值