Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12377 Accepted Submission(s): 7698
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
题目大意:
房间由黑色和红色地板铺成,一个人站在黑色地板上,位置为@,他可以向着上下左右四个方向移动,黑色可走,红色不可走,看其可以坐多少个黑色地板。
解题思路:
这是一道图形深搜,深搜也就是递归的一种,其边界条件就是图形的边界还有不能是‘#’,然后在递归调用本身。如何控制上下左右移动呢?那就是建立两个数组,一个存放X的变化,一个存放Y的变化,其值对应上下左右移动X或Y的变化,记住要一一对应。
每深搜递归调用一次,sum++,然后将其标记为#,避免重复。
#include<stdio.h>
int xx[5]={0,0,-1,1};
int yy[5]={1,-1,0,0};//上下左右移动
char map[22][22];
int n,m;
int sum;
int judge(int x,int y)
{
if(x<1||x>m||y<1||y>n)
return 0;
if(map[x][y]=='#')
return 0;
else
return 1;
}
void DFS(int x,int y)
{
int i,j;
int nowx,nowy;
sum++;
map[x][y]='#';//标记,避免重复
for(i=0;i<4;i++)
{
nowx=x+xx[i];
nowy=y+yy[i];
if(judge(nowx,nowy))
DFS(nowx,nowy);
}
}
int main()
{
int stax,stay;
int i,j;
while(scanf("%d%d",&n,&m),n+m)
{
for(i=1;i<=m;i++)
{
getchar();//将换行排除
for(j=1;j<=n;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@')
{
stax=i;
stay=j;
}
}
}
sum=0;
DFS(stax,stay);
printf("%d\n",sum);
}
return 0;
}