L1-5 不变初心数 (15 分)(C/C++)

在这里插入图片描述
输入样例:

4
18
256
99792
88672

输出样例:

9
NO
36
NO
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cstdlib>
#include<algorithm>
#include<string.h>
#include<math.h>
#define llu unsigned long long
using namespace std;

//L1-5 不变初心数 (15 分)
int main()
{
	int n;
	cin >> n ;
	while(n--)
	{
		int ans=0;
		int x,ff=0,fff=1; 
		cin >> x ;
		for(int i=2;i<10;i++)
		{
			ff=0;
			if(i==2)ff=1;
			int a=x*i/100000;
			int b=x*i%100000/10000;
			int c=x*i%10000/1000;
			int d=x*i%1000/100;
			int e=x*i%100/10;
			int f=x*i%10;
			int t=a+b+c+d+e+f;
			if(ff)ans=t;
			else if(ans!=t){
				fff=0;
				break;
			}
		}
		if(fff)cout << ans << endl ;
		else cout << "NO" << endl ;
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值