hdu 2053隐藏的快速算法,求约数即可【复习】

Switch Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7429    Accepted Submission(s): 4413


Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 

Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
 

Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 

Sample Input
  
  
1 5
 

Sample Output
  
  
1 0
#include<iostream>
using namespace std;
char str[1000000];
main()
{
long n,k,i,j;

      while(cin>>n);
      {
          for(k=n;k>=1;k=k-1)
          {
          str[k]=0;
          }
            for(i=1;i<=n;i=i+1)    //i表示每一次操作 
            {
                for(j=1;j<=n;j=j+1)    //j表示对第j个数操作 
                {
                    if(j%i==0) 
                    {
                     if(str[j]==0) str[j]=1;
                     if(str[j]==1) str[j]=0;
                    }
                }
            }
      cout<<str[n]<<endl;
      
      }
return 0;
}


优化后的代码,求第n个数有多少约数即可



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值