Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90
这个题输入16进制,两数相加输出16进制。
在c++中,输入输出16进制需要在输入输出流中加上hex。
setiosflags(ios::uppercase)控制16进制数大写输出。
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
long long a,b,sum;
while(cin>>hex>>a>>b)
{
sum=a+b;
if(sum<0)
{
sum=-sum;
cout<<'-';
}
cout<<setiosflags(ios::uppercase)<<hex<<sum<<endl;
}
}