题目:
话说大诗人李白,一生好饮。
幸好他从不开车。
一天,他提着酒壶,从家里出来,酒壶中有酒 22 斗。
他边走边唱:
无事街上走,提壶去打酒。
逢店加一倍,遇花喝一斗。
这一路上,他一共遇到店 N次,遇到花 M 次。
已知最后一次遇到的是花,他正好把酒喝光了。
请你计算李白这一路遇到店和花的顺序,有多少种不同的可能?
注意:壶里没酒 (0 斗) 时遇店是合法的,加倍后还是没酒;但是没酒时遇花是不合法的。
输入格式
第一行包含两个整数 N 和 M。
输出格式
输出一个整数表示答案。由于答案可能很大,输出模 1000000007 的结果。
数据范围
对于 40% 的评测用例:1≤N,M≤10。
对于 100%的评测用例:1≤N,M≤100。输入样例:
5 10
输出样例:14
样例解释如果我们用 0 代表遇到花,1 代表遇到店,14 种顺序如下:
010101101000000
010110010010000
011000110010000
100010110010000
011001000110000
100011000110000
100100010110000
010110100000100
011001001000100
100011001000100
100100011000100
011010000010100
100100100010100
101000001010100
注意: 暴搜可能会超时的,只能得到这道题百分四十的的分数
思路:正确设置dfs中的参数,遍历每一种可能
全部代码:
#include<iostream>
using namespace std;
int n, m;
int ans;
//step ==1表示花,step==0表示酒店
void dfs(int x,int y,int wine,int step) {
if (wine < 0) {
return;
}
if (x > n || y > m) {
return;
}
if (x == n && y == m && wine == 0 && step==1 ) {
ans++;
return;
}
dfs(x, y + 1, wine -1 ,1);//遇花
dfs(x + 1, y, wine* 2,0);
}
int main() {
cin >> n >> m;
dfs(0, 0, 2,0);
cout << ans % 1000000007 << endl;
return 0;
}
(2)输出所有解:
在dfs函数中添加一个参数 k记录
#include<iostream>
using namespace std;
int n, m;
int ans;
int a[10005];
int k = 0;
//step ==1表示花,step==0表示酒店
void dfs(int x,int y,int wine,int step,int k) {
if (wine < 0) {
return;
}
if (x > n || y > m) {
return;
}
if (x == n && y == m && wine == 0 && step==1 ) {
for (int i = 1; i <= n+m; i++) {
cout << a[i];
}
cout << endl;
ans++;
return;
}
if (step == 0) {
a[k] = 1;
}
else a[k] = 0;
dfs(x, y + 1, wine -1 ,1,k+1);//遇花
dfs(x + 1, y, wine* 2,0,k+1);
}
int main() {
cin >> n >> m;
dfs(0, 0, 2,1,0);
cout << ans % 1000000007 << endl;
return 0;
}